Implement add-on abuse communication channel

VERIFIED DUPLICATE of bug 472399

Status

addons.mozilla.org Graveyard
Public Pages
P3
normal
VERIFIED DUPLICATE of bug 472399
8 years ago
2 years ago

People

(Reporter: jorgev, Unassigned)

Tracking

unspecified
4.x (triaged)

Details

(Whiteboard: [ReviewTeam])

(Reporter)

Description

8 years ago
Users have a hard time trying to contact us regarding abusive add-ons. Some resort to negative reviews (which we rarely check), and very few manage to find the amo-editors or amo-admins addresses.

I think there should be a "Report Abuse" link on every add-on page. I think below the "Share this Add-on" link is a good place. This should open a form where the user can type the explanation and submit it.

The abuse reports would not be public, but it'd be good to encourage users to provide an email address for questions. They should appear as a new list in the Editor Tools. It should be possible to delete reports that are irrelevant or no longer useful, and to see which add-ons are receiving the most abuse reports.

This will give us better control of misbehaving add-ons, and users will be happier with the additional communication channel.

Comment 1

8 years ago
Similar to bug 472399. Probably could have one "report" link for all issues.
(Reporter)

Comment 2

8 years ago
Ha, I even commented on it. I guess it's a dupe.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 472399

Updated

8 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 3

6 years ago
Reclassifying editor bugs and changing to a new whiteboard flag. Spam, spam, spam, spam...
Whiteboard: [required amo-editors] → [ReviewTeam]
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.