[GMail] Sending a draft doesn't remove the draft, saving a draft duplicates it.

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
9 years ago
8 years ago

People

(Reporter: wyuenho, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2011-03-15])

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10_5_8; en-us) AppleWebKit/531.21.8 (KHTML, like Gecko) Version/4.0.4 Safari/531.21.10
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9.1.7) Gecko/20100111 Lightning/1.0b1 Thunderbird/3.0.1

Using the recommended account settings for GMail, sending a saved drafts doesn't clear it's draft status and remove it from the draft box. Furthermore, pressing the save button while editing a draft duplicates that draft on the server.

Reproducible: Always

Steps to Reproduce:
1. Go to Account Setting and set the Gmail account using IMAP according to the recommended Gmail settings.
2. Compose and email and wait til autosave has saved an email into the draft box on the server.
3. Press the save button in the compose email window
4. Send the draft.
Actual Results:  
The draft is still saved as a draft after sent, and manually saving the draft duplicates that draft on the server. Visiting the draft box sees the old drafts that should have been deleted are only marked as deleted, but not actually removed or archived. Visiting Gmail sees those old drafts as just another version in a draft "conversation". These behavior are inconsistent with TB 2.

Expected Results:  
Drafts that are sent should be removed completely form the draft box, and manually saving a new draft should not duplicate that draft.

http://mail.google.com/support/bin/answer.py?answer=78892
> Expected Results:  
> Drafts that are sent should be removed completely form the draft box, (snip)

What IMAP folder do you use as "folder to save draft mail"?
Old draft mail is really still held in "Draft" IMAP folder(Gmail Label of "[Imap]/Drafts") or "[Gmail]/Drafts" IMAP folder(Gmail Label/Folder of "Drafts")?
Or Tb's thread display only issue?

Show "Order Received" column(UID of mail if IMAP), read thru bug 402132, get IMAP log, and check IMAP level flow first. Which mail(UID) is not deleted? Is there any fault of Tb around draft save/draft delete seen in log?
nspr_log_modules=timestamp,imap:5 will add timestamp to log. It'll help your log analysis.

What is your IMAP delete model? ("Mark as deleted" model because you say next)
> Visiting the draft box sees the old drafts that should have been deleted are only marked as deleted
If "0 mails" condition occurs, bug 462880 can happen.
Does "compact" of the folder removed all mark-as-deleted mails from thread pane?
Keep at least one alive draft mail in folder you use as "folder to save draft".
Is your problem still re-produced?
This sounds like bug 492267
Please comment whether you still see this issue.
And see questions in comment 1.
Whiteboard: [closeme 2011-03-15]
RESOLVED INCOMPLETE due to lack of response to previous question. If you feel this change was made in error, please respond to this bug with your reasons why.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.