Geolocation doesn't work on T-Mobile Internet

RESOLVED WORKSFORME

Status

Firefox for Android Graveyard
General
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: Victor Quach, Unassigned)

Tracking

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.8pre) Gecko/20100114 Ubuntu/9.10 (karmic) Shiretoko/3.5.8pre
Build Identifier: 1.00 (RC2) for the N900

Use any geolocation service: Google Mobile Maps, Flickr's World Map, Near Me extension, etc while on T-Mobile Internet. A prompt will ask you if you want to allow them access to your location, click yes/enable.

Watch as the circle keeps spinning, spinning, and spinning. Give up whenever you want. This happens on 2.5G or 3G and it won't matter how long you let it sit. 

I've tried changing the stun server from supl.nokia.com to supl.google.com
N900 using Fennec RC2 (1.00)


Reproducible: Always

Steps to Reproduce:
1.Use any geolocation service: Google Mobile Maps, Flickr's World Map, Near Me extension, etc while on T-Mobile Internet
2.A prompt will ask you if you want to allow them access to your location, click yes/enable.
3.Watch as the circle spins forever
Actual Results:  
The circle just keeps spinning and it can't find your location.

Expected Results:  
It should find your location and show results near you. 

Interestingly, using the same websites that use your location in microB (the default Maemo browser) works fine. Even if I disable the Internal GPS and use the network positioning only. And vice-versa. 

So this problem seems only limited to either Fennec, or something in my install. However, I've reinstalled Fennec, I've uninstalled Fennec (deleted the folder, rebooted, and reinstalled), I've re-flashed and reninstalled Fennec. Yet I can't seem to get this to work.

Comment 1

8 years ago
what is your ip address when you see this problem?

it might be the case that your ip address that is handed to you by TMobile isn't know by the geolocation service we use.
(Reporter)

Comment 2

8 years ago
Where I am now it says my IP address is 208.54.90.61

The odd thing is that it works just fine in the default browser (microB), even if I disable the internal GPS.
Victor, can you try it again on a nightly build: http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mobile-1.9.2/


Doug, what was the bug id of the geolocation code you landed onto platform that uses the device's geolocation api's ?
(Reporter)

Comment 4

8 years ago
Aakash, thanks! I've tested it a few times and I can confirm that the nightly build fixed the geolocation.
Ok, marking worksforme, since this bug seems to be not there anymore and I don't know the bug id of which this was probably fixed (of which Doug Turner might know).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
And thanks for retesting, Victor.

Updated

8 years ago
Component: Linux/Maemo → General
OS: Linux → Linux (embedded)
QA Contact: maemo-linux → general
Hardware: Other → ARM
You need to log in before you can comment on or make changes to this bug.