Mail Account Setup does not re-validate server settings if manually changed after validation is done

NEW
Unassigned

Status

Thunderbird
Account Manager
9 years ago
2 years ago

People

(Reporter: Ian Graham, Unassigned)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
Steps to reproduce:

1. Start mail account setup wizard and enter some settings to configure 
   new inbound, outbound servers, etc, and launch the configuration wizard.
2. Press 'Stop' before validation is complete, but after one item 
   (e.g. the SMTP server) has been validated (e.g. there is the nice little
   green ball to the left of the item)
3. Modify the SMTP properties to something impossible (e.g. port=321)
4. Press "Re-test configuration"  - note that the SMTP server settings are not
   re-validated: they are left as green (accurate), even though the visually
   displayed settings (e.g. port=321) is invalid.
5. When you complete validation and 'create' the new mail account, the 
   user changes from step 3 are ignored: the wizard uses the values discovered
   by the wizard, and ignores the additional user input. 

Expected behavior: one of a) or b)

a) When validation is completed for an item, the user should not be able to
   modify the parameters for that item.
b) if the parameters are modified, then the settings should be re-validated
   when the wizard is restarted. 

Note: I only tested this for the case where the SMTP server is validated (and marked 'green') first - I had no way to check what happens if a POP or IMAP server is the first marked as 'done,'
That's valide for smtp only right ?

Blake do you need more information ?
No, that should be enough information for me to try to replicate this.
Assignee: nobody → bwinton
Status: NEW → ASSIGNED

Updated

7 years ago
Duplicate of this bug: 625767
I'm not really working on these, so I'm freeing them up for a community member to take.
(Filter on [ossifrage] to delete all the notifications.)
Assignee: bwinton → nobody
Status: ASSIGNED → NEW
You need to log in before you can comment on or make changes to this bug.