If you place a large number of bookmarks in a folder, then go to Bookmarks ▸ (folder name) ▸ "open all in tabs," sometimes they won't open.

NEW
Unassigned

Status

()

--
minor
9 years ago
7 years ago

People

(Reporter: jonathandl92, Unassigned)

Tracking

3.6 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.2) Gecko/20040804 Netscape/7.2
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7

If you place a large number of bookmarks in a folder, then close all Firefox windows, then go to Bookmarks ▸ (folder name) ▸ "open all in tabs," then all pull-down menus except the Apple and Firefox menus will disappear, and no new Firefox window will open.

Operating system:  Mac OS 10.4.11 (Tiger).

Reproducible: Sometimes

Steps to Reproduce:
1. In Preferences, be sure that "Warn me when opening multiple tabs might slow down Firefox" is checked.
2. Go to Bookmarks ▸ Organize Bookmarks and create a folder.
3. Bookmark a large number of pages (at least 15).  When bookmarking each page, put it in the folder you created in step #2 above.
4. Quit Firefox.
5. Reopen Firefox, and close the window.
6. Go to Bookmarks ▸ the folder you created in step #2 above ▸ "open all in tabs."
Actual Results:  
No window opens.  In addition, all pull-down menus except the Apple menu and Firefox application menu disappear.

Expected Results:  
Either a new window opens with the desired tabs, or a dialog box pops up saying that you are about to open a certain number of tabs and inquiring whether you want to continue or not.

Problem goes away if you go to Preferences and uncheck "Warn me when opening multiple tabs might slow down Firefox."
How do you select "open all in tabs" from the main menu? We do not have a context menu for menu entries on OS X.
(Reporter)

Comment 2

9 years ago
It's there.  When you create a Bookmarks folder inside the Bookmarks menu, then that folder becomes a sub-menu of the Bookmarks menu, and you have the option of opening all the bookmarks in that sub-menu in tabs.
Alright. Sorry for the confusion. So to getting closer to your issue please try the following:

* Find some steps which make this bug reproducible
* Check the Error Console for reported errors when the bug happens
* When you have clear steps please try to run Firefox in Safe Mode (http://support.mozilla.com/kb/Safe+Mode)
Reporter, are you still seeing this issue with Firefox 3.6.13 or later in safe mode or a fresh profile? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles
Whiteboard: [CLOSEME 2011-2-25]
This bug has had the CLOSEME tag for several weeks and the date in the tag is far gone. If the reporter can still see this issue, Please retest with Firefox 3.6.x or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). Then please remove the closeme tag in the whiteboard, mark the bug against the proper version and comment on the bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 6

8 years ago
I have confirmed that the bug still exists in version 3.6.15 for Macintosh, with a clean install [in fact, since the date I originally opened the bug, the hard drive has been reformatted (for unrelated reasons) and the entire operating system has been reinstalled.]

Furthermore, it only occurs if the preference to "Warn me when opening multiple tabs might slow down Firefox" is checked.  It does not matter, however, whether Firefox is started with the Option key (in safe mode) or not.

Unfortunately, the bug causes the Tools menu to disappear, and the Error Console is located within the Tools menu.  Please change the status of this bug to "reopened."

Thank you.
Status: RESOLVED → VERIFIED
Whiteboard: [CLOSEME 2011-2-25]
Version: unspecified → 3.6 Branch

Updated

8 years ago
Status: VERIFIED → UNCONFIRMED
Resolution: INCOMPLETE → ---

Comment 7

8 years ago
Reporter -> Are you still experiencing this issue with the latest version of Firefox 4? Does the issue occur with the latest nightly? http://nightly.mozilla.org/
(Reporter)

Comment 8

8 years ago
I do not meet the minimum system requirements for Firefox 4, and cannot vouch for the existence of this bug in any platform other than Mac OS 10.4.x "Tiger."
Jonathan, we are still waiting for your reply to comment 4. If you have time please check this advice. Thanks.
Hardware: x86 → PowerPC
(Reporter)

Comment 10

8 years ago
I have already replied to comment 4.  Not sure what else you want me to do at this point?
Hardware: PowerPC → x86
You have reinstalled Firefox and tested again, but you haven't mentioned yet, if you have tested in Safe Mode or a fresh profile too. By reinstalling the application the old profile still remains, so it could still be the reason why the issue is still persistent.

Comment 12

7 years ago
Reporter -> Are you still experiencing this issue? Have you tried safe mode or a new profile?
(Reporter)

Comment 13

7 years ago
(In reply to comment #11)
> You have reinstalled Firefox and tested again, but you haven't mentioned
> yet, if you have tested in Safe Mode or a fresh profile too. By reinstalling
> the application the old profile still remains, so it could still be the
> reason why the issue is still persistent.

I indicated that I had reinstalled Firefox after reinitializing the hard drive; thus, it was a clean reinstall.
(Reporter)

Comment 14

7 years ago
I have verified that this issue still occurs in Firefox version 3.6.17, even in safe mode.  Thank you.

Comment 15

7 years ago
Marking as confirmed; this bug has had repeated confirmation.
Status: UNCONFIRMED → NEW
Ever confirmed: true
You need to log in before you can comment on or make changes to this bug.