If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Opening JavaScript chromeless windows renders Firefox functional but unusable.

RESOLVED WORKSFORME

Status

()

Firefox
General
--
critical
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: doggitydogs, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20100116 Minefield/3.7a1pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20100116 Minefield/3.7a1pre

If a JavaScript chromeless window is opened from within the last build from 2010/01/08, when the window is closed, new tabs cannot be opened, pages cannot be reloaded, nothing can be entered into the address bar, drop-down menus cannot be opened, and the Close button doesn't work, so the process has to be killed directly. After doing so, the Restore Session screen only works half the time (but always appears).

Reproducible: Always

Steps to Reproduce:
1. Open a JavaScript chromeless window.
2. Close it.
3. Try to use the address bar.
4. Try to close Firefox.
Actual Results:  
The address bar didn't work, and Firefox wouldn't close.

Expected Results:  
Well, that was expected, but, ideally, everything would have kept working.

Extensions:
All-Glass Firefox mod, based on Glasser
Fission
Omnibar
Personal Menu
NEW Glasser by SzymekPL
Nightly Tester Tools
StrataBuddy
Stylish
Tab Progress Bar
Using theme Strata40.
Using plugins:
Adobe Acrobat 8.1.3.187
Google Update 1.2.183.13
IE Tab Plug-in 1.6.3.260
Java Deployment Toolkit 6.0.170.4 6.0.170.4
Java(TM) Platform SE 6 U17 6.0.170.4
Microsoft Office 2010 14.0.4514.1004
Microsoft Office 2010 14.0.4514.1004
Mozilla Default Plug-in 1.0.0.15
Picasa 3.0.0.0
Shockwave Flash 10.0.32.18
Silverlight Plug-In 3.0.40818.0
Windows LiveĀ® Photo Gallery 14.0.8081.709
1920x1024 display, 4GB RAM, 1GB GRAM
After loading: window.open ('about:mozilla', 'test2', 'chrome=no,width=320,height=240'); in the Error Console
and subsequently closing the window, I see no problem.

Does it also fail in safe-mode / with a new profile?
http://support.mozilla.com/en-US/kb/Troubleshooting+extensions+and+themes
http://support.mozilla.com/en-US/kb/Basic+Troubleshooting#Make_a_new_profile
Version: unspecified → Trunk
(Reporter)

Comment 2

8 years ago
It seems to be working now... you're magic!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
Version: Trunk → unspecified
I know ;)
You need to log in before you can comment on or make changes to this bug.