If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

View settings such as view unread only are lost when a mailbox is compacted

RESOLVED WORKSFORME

Status

Thunderbird
Folder and Message Lists
--
major
RESOLVED WORKSFORME
8 years ago
6 years ago

People

(Reporter: Randy Smith, Unassigned)

Tracking

({regression})

x86
Windows XP
regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dupeme][datalossy])

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.7) Gecko/20100110 Shredder/3.0.1pre

When Thunderbird automatically compacts a mailbox, my view preferences -- specifically view unread only -- are lost and have to be set again.

Reproducible: Always

Steps to Reproduce:
1.  Set view to unread only on a mailbox (view... threads... unread)
2.  Set "Compact folders when it will save over " to a small number and enable (the problem didn't seem to occur when using a manual compact).
3.  POP some messages to the box and delete them (I used shift delete).
4.  Thunderbird should compact the mailbox and lose the view settings.
Actual Results:  
Thunderbird should compact the mailbox and lose the view settings.

Expected Results:  
View settings should not be affected by a compact.

This has happened on both Thunderbird 3.0 release and the nightly build I am currently running.
Was it happening in version 2 ?
(Reporter)

Comment 2

8 years ago
I never had this problem in V2.
Keywords: regression
this is fundamentally a compact issue which has always exist, but the compacts mighit be happening more frequently in v3.
Severity: minor → major
Whiteboard: [dupeme][datalossy]
Version: unspecified → 3.0
Perhaps rkent recalls the bug which may have fixed this.

If not, Randy's address bounces and a similar bug [1] recently closed as WFM. So, with no other reporters and steps which no longer reproduce the issue, closing incomplete. 

[1] Bug 509042 Summary: Junk, Sent, and Trash Folders Occasionally Lose Sort Order and Retention Policy Settings after auto-compact
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 5

6 years ago
I don't know why your email to me was bouncing, but I received an email of this status update.  I tested the problem and it no longer seems to occur.

Thanks!
Randy
Randy, thanks for the update
Resolution: INCOMPLETE → WORKSFORME
You need to log in before you can comment on or make changes to this bug.