invalid HTML (a misplaced closing </UL>) causes the style of a link to overflow.

RESOLVED INVALID

Status

()

Core
HTML: Parser
P3
minor
RESOLVED INVALID
18 years ago
17 years ago

People

(Reporter: Alex Stewart, Assigned: rickg)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.14 i586; en-US; m18) Gecko/20000925
BuildID:    2000091312

The bug only occurs inside a table.  The order of the closing UL and A tags are
reversed.  http://www.student.math.uwaterloo.ca/~am2stewa/new5.html shows what
happens when there is no table (correct rendering).
http://www.student.math.uwaterloo.ca/~am2stewa/new4.html shows what happens when
the ordering is fixed (correct rendering).  All three render correctly in NS 4.7
and M17.  The new6.html page is an excerpt
from a cbc.ca page.

Reproducible: Always
Steps to Reproduce:
1. Go to http://www.student.math.uwaterloo.ca/~am2stewa/new6.html
2. Observe.
3.

Actual Results:  Saw incorrect layout						

Expected Results:  Saw layout similar to http://www.student.math.uwaterloo.ca/~am2stewa/new4.html						

Also seen in 2000091908 (which I d/led first...it seems like all the
newer builds have 2000091312 as their ID...but the User Agent reflects the
folder I d/led from)  Similar to bug 991?

The additional paragraph was included to show that some correct HTML
fixes the problem.

<UL><LI><A HREF="http://www.mozilla.org/">blah</UL>
</A> Markup with wrong style.

Comment 1

18 years ago
Bad HTML, The tags arn't nested properly and the LI isn't closed marking INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID

Comment 2

17 years ago
updated qa contact.
QA Contact: janc → bsharma

Updated

17 years ago
QA Contact: bsharma → moied
You need to log in before you can comment on or make changes to this bug.