Suggestion list at wrong position

RESOLVED DUPLICATE of bug 389365

Status

()

Firefox
Search
RESOLVED DUPLICATE of bug 389365
8 years ago
8 years ago

People

(Reporter: Konrad Windszus, Unassigned)

Tracking

3.6 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6

I have two monitors connected and use them not synchronized (meaning one extends the other). They are positioned next to each other. The right one is the primary display (the one with the dock bar and the menus). If I know maximize the firefox window on this first display, the suggestion list for the search (Google, Wikipedia, etc) is shown at the right position (right below the toolbar search field). If I now move the window just a littlebit to the left, so that it appears with with one or two pixels width on the left monitor but with the rest still on the main (right) monitor, the suggestion list is displayed on the left monitor.

Reproducible: Always

Steps to Reproduce:
1. Use two monitor in extended view and make the right one the primary display.
2. Start Firefox and maximize the window on the right monitor.
3. Move the window a littlebit to the left (so that it just appears on the other display)
4. Enter some search term in a search engine supporting suggestions (e.g. Google or Wikipedia)
Actual Results:  
The suggestion list appears on the wrong monitor (the right one).

Expected Results:  
The suggestion list should appear right below the toolbar search field.
Nice catch. Looks like this is the only pop-up left which opens at the wrong screen. Confirmed with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2pre) Gecko/20100115 Namoroka/3.6pre ID:20100115050432
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → 3.6 Branch
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 389365
You need to log in before you can comment on or make changes to this bug.