Closed Bug 540516 Opened 11 years ago Closed 11 years ago

Usability: Allow users to clear HTTP Basic authentication details ('Logout')

Categories

(Firefox :: General, enhancement)

x86
Windows XP
enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 300002

People

(Reporter: daniel.oconnor, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7 (.NET CLR 3.5.30729)

See also Bug 521588

When you authenticate with a site using HTTP Basic authentication, there is no visibility of your current credentials in the firefox UI.

Additionally, there is no obvious/easy mechanism to logout.

Consider adding a method to clear HTTP Basic Auth credentials easily.

Reproducible: Always
Clear Recent History->Active Logins (in the details) is used to clear the authentication.
Though that works, it's hard to locate. Additionally, it's the nuclear option: You can't 'log out' of just one site, it's everything.

I'd love to see this represented more obviously. Bug 521588 mentions it in passing. 


I'd visualize this as either appearing in the location bar or near the HTTPS 'secure' padlock.

IE

[[mozilla.org] username @ https://bugzilla.mozilla.org/show_bug.cgi ]

or

"User: username [Logout]"
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 300002
You need to log in before you can comment on or make changes to this bug.