All users were logged out of Bugzilla on October 13th, 2018

addon's preview screenshots need to be grouped by addon's version

RESOLVED WONTFIX

Status

--
enhancement
RESOLVED WONTFIX
9 years ago
3 years ago

People

(Reporter: the_herd_of_the_horses, Unassigned)

Tracking

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7
Build Identifier: 

Only the latest version screenshots should be displayed at addon's page; when I click "all versions", I should see screenshots for each version

Reproducible: Always

Steps to Reproduce:
1.create new add-on XXX version 0.001
2.upload version 1 screenshots
3.upload new version for it, v.2
4.add new screenshots
Actual Results:  
All screen-shots appear at addon's page in one pile.

Expected Results:  
The developer should have been able to upload screen-shots by version. They should appear at the all versions public page immediately.
Only latest version screenshots  should appear at addon's page. "Latest version" means latest public version: for example, if version 2 has been reviewed, and 3 is in sandbox, than v.2 screen-shots should be at the addon's public page.

Some screen-shots can also apply to several versions if the addon's GUI changed little.
Confirming as an RFE, but this is up to the product/development team.
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

9 years ago
Do you mean that this bug should be forwarded to a certain team leader/manager? What is "RFE"?
RFE=request for enhancement.  Confirming doesn't mean we'll fix the bug, just that we'll consider it, thus the 2nd portion of my comment.
Jorge: any thoughts on this?  I think images per-version would just add confusion, e.g. "I uploaded a new version and all my pictures disappeared"
Yeah, I don't see any clear benefit from doing this, and it's very likely to cause trouble to authors and users alike. Recommend WONTFIX.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 6

9 years ago
By default, images should not disappear. :) 

But if some images are now too old for current version, then the developer should have an option/possibility of assigning the older images to older versions.

Because, otherwise older images have to be thrown away (alt: image gallery cluttered with obsolete images); besides, versions are easier to recognize when some of them have images... 

For example, some feature didn't work in version N, was temporarily removed in versions N+1 and N+2, now the developer wants to return to it and has to look at the release notes. 

Or, a user wants older GUI - how does he write a support request if he can't exactly know what is the version with "pretty" GUI? He must have already updated, and can probably not remember what the version number was prior to the update.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
This is too much work for AMO developers and add-on authors, and I don't see anybody else asking for this feature.

Most authors are happy keeping their images up to date with the latest version, or just keeping old images. The image previews are not that crucial a feature to warrant having a complete, messy versioning system.
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.