Bandwagon API Returns "500 Internal Server Error"

RESOLVED WORKSFORME

Status

addons.mozilla.org Graveyard
API
RESOLVED WORKSFORME
8 years ago
2 years ago

People

(Reporter: mackers, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7
Build Identifier: 

I'm testing bandwagon (Add-on Collector) with the following collection:

https://addons.mozilla.org/en-US/mobile/collection/fennec-amo

Retrieving the feed for this collection via the API returns "500 Internal Server Error".

This seems to happen for all users. I can't reproduce with any other collection feed.

Below is the HTTP dialog:

$ curl --verbose -u me@mackers.com "https://addons.mozilla.org/en-US/firefox/api/1.3/sharing//collections/4e719fab-46db-7646-3cd3-93a513ed00ed/?__=1263904432786"
Enter host password for user 'me@mackers.com':
* About to connect() to addons.mozilla.org port 443
*   Trying 63.245.213.91... connected
* Connected to addons.mozilla.org (63.245.213.91) port 443
* successfully set certificate verify locations:
*   CAfile: /etc/ssl/certs/ca-certificates.crt
  CApath: none
* SSLv2, Client hello (1):
SSLv3, TLS handshake, Server hello (2):
SSLv3, TLS handshake, CERT (11):
SSLv3, TLS handshake, Server finished (14):
SSLv3, TLS handshake, Client key exchange (16):
SSLv3, TLS change cipher, Client hello (1):
SSLv3, TLS handshake, Finished (20):
SSLv3, TLS change cipher, Client hello (1):
SSLv3, TLS handshake, Finished (20):
SSL connection using RC4-SHA
* Server certificate:
* 	 subject: /1.3.6.1.4.1.311.60.2.1.3=US/1.3.6.1.4.1.311.60.2.1.2=California/2.5.4.15=V1.0, Clause 5.(b)/serialNumber=C2759208/C=US/ST=California/L=Mountain View/O=Mozilla Corporation/OU=Mozilla Add-ons/OU=Terms of use at www.verisign.com/rpa (c)05/CN=addons.mozilla.org
* 	 start date: 2009-08-21 00:00:00 GMT
* 	 expire date: 2011-08-21 23:59:59 GMT
* 	 common name: addons.mozilla.org (matched)
* 	 issuer: /C=US/O=VeriSign, Inc./OU=VeriSign Trust Network/OU=Terms of use at https://www.verisign.com/rpa (c)06/CN=VeriSign Class 3 Extended Validation SSL CA
* SSL certificate verify ok.
* Server auth using Basic with user 'me@mackers.com'
> GET /en-US/firefox/api/1.3/sharing//collections/4e719fab-46db-7646-3cd3-93a513ed00ed/?__=1263904432786 HTTP/1.1
> Authorization: Basic bWVAbWFja2Vycy5jb206Y2hhMnJC
> User-Agent: curl/7.15.5 (x86_64-pc-linux-gnu) libcurl/7.15.5 OpenSSL/0.9.8c zlib/1.2.3 libidn/0.6.5
> Host: addons.mozilla.org
> Accept: */*
> 
< HTTP/1.0 500 Internal Server Error
< Server: Apache
< Content-Type: text/html; charset=UTF-8
< Date: Tue, 19 Jan 2010 12:39:24 GMT
< X-AMO-ServedBy: pm-app-amo20
< Via: Moz-Cache-ams-zlb03
< Connection: close
< X-Powered-By: PHP/5.2.9
< X-Cache-Info: not cacheable; response code not cacheable
< X-Cache-Info: not cacheable; response code not cacheable
< Content-Length: 0
* Closing connection #0
* SSLv3, TLS alert, Client hello (1):


Reproducible: Always
(Reporter)

Comment 1

8 years ago
I'm not seeing this anymore. Must have been a temporary thing.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME

Updated

8 years ago
Duplicate of this bug: 527341
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.