SwitchProxy Tool: Incorrect compatibility listed: 1.0 – 3.6.*; should be 1.0-3.0

RESOLVED FIXED

Status

--
critical
RESOLVED FIXED
9 years ago
3 years ago

People

(Reporter: cerieljacobs, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_2; en-US) AppleWebKit/532.5 (KHTML, like Gecko) Chrome/4.0.249.49 Safari/532.5
Build Identifier: n/a

his extension unfortunately doesn't work no longer after upgrading from Firefox 3.0.17 to 3.5.7. When enabled the browser is brought to its knees within a few clicks. After hours if searching and enabling/disabling plugins and switching Firefox versions and profiles, my eye felt on a note in the extension window, stating that "compatibility updates were applied". After closer investigation of these extensions, this Switch Proxy Tool 1.4.1 seems to be the cause from this bad upgrade experience. The issues range from tabs that cannot be closed, links that cannot be clicked, the FEBE extension welcome page where all text is gone (images and bullets shown), the browser that lost all its profile preferences (this is really frighting), etc...

Reproducible: Always

Steps to Reproduce:
1. Create new profile
2. Install this extension
3. As soon as firefox 3.5+ restart, you able to type a uri into the address bar
4. To confirm and start loading that uri: press the <enter>key 
Actual Results:  
The <enter> key is no longer accepted, result: you are not able to load a uri.

Any hyperlinks on the pages that are opened cannot be clicked.


Please update the listing for SwitchProxy tool <> soon.

Reason 1: There is already a full page <https://addons.mozilla.org/en/firefox/reviews/display/125> of comments that Switch Proxy Tool 1.4.1 breaks on 3.5+

Reason 2: New upgraders will get a very bad Firefox upgrade experience: their browser feels like fully crashed.
Component: Public Pages → Administration
QA Contact: web-ui → administration

Comment 1

8 years ago
Not able to find the Switch Proxy Tool add-on to verify this behavior
This add-on was admin-disabled at some point, so this is no longer an issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.