Delete messages from Newsgroups failed in Netscape 6.0

VERIFIED DUPLICATE of bug 39692

Status

MailNews Core
Networking: NNTP
P3
normal
VERIFIED DUPLICATE of bug 39692
17 years ago
9 years ago

People

(Reporter: Shirley Liu, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
Sun
Solaris

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: suntrak-n6)

(Reporter)

Description

17 years ago
1. Login the Netscape 6.0 Mail System.
2. Double click a newsgroup account.
3. News listing showed up.
4. Highlight a mail sent from the login user and then click the delete button.
5. Mail was not deleted.

Mail should be deleted by the login user if the mail was posted by
himself/herself.
(Reporter)

Comment 1

17 years ago
It should have a message stating that you can not delete the message if you are
not the one who posted the message into the Newsgroup.

Comment 2

17 years ago
This is a Mial-News bug, not a Browser bug.
Assignee: asa → sspitzer
Component: Browser-General → Networking - News
Product: Browser → MailNews
QA Contact: doronr → esther
(Reporter)

Comment 3

17 years ago
Enabled Mail System Menu -> View -> Toolbars -> Mail Toolbar. Click the Delete
button on the Mail Toolbar. 
(Reporter)

Comment 4

17 years ago
The Build ID is 2000090913 for Sparc Solaries 2.8.
(Reporter)

Comment 5

17 years ago
The delete button is the Mail Tool Delete Button.
(Reporter)

Comment 6

17 years ago
The delete button is the Mail Tool Delete Button.
Whiteboard: suntrak-n6
this is a duplicate of another bug.

I'll go find it.

the proper fix will be to remove or disable the delete button when viewing news.
(we did this in 4.x)

the way to cancel is "Edit | Delete Message"  which is supposed to say "Edit |
Cancel Message" when viewing news.  (there is also another bug on that.)
see bugs
#8293:  [NEWS]UI: Edit | Delete Message should turn into Edit | Cancel Message
#39692: Remove Delete button when a News item is selected

marking a dup of 39692.  once that bug is fixed, this will not be a problem.



*** This bug has been marked as a duplicate of 39692 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 9

17 years ago
marking verified as a duplciate
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.