Closed Bug 540840 Opened 11 years ago Closed 11 years ago

when saving attachments, Win XP file picker uses "All Files" filter

Categories

(Thunderbird :: OS Integration, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 414865

People

(Reporter: rl, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7
Build Identifier: up to Shredder/3.0.2pre

In a standard Win XP installation, the file picker will show a file name "foo" for a file actually named "foo.doc" and only allow the "All files" filter.
Changing the file name in the Windows XP file picker removes the filetype extension as well.
A user trying to save an attached Word document "foo" (as shown in the file picker) as "bar" will actually change the filename from "foo.doc" to "bar", resulting in a file with no file type.

This is not only confusing for users, it is also inconsistent: if you get to the file picker through the action/open dialog (instead of ), the filetype filter does reflect the file type of the attachment and changing the filename will not affect the filename extension.

In short:
File->Attachments->foo.doc->Save As... [BROKEN]
File->Attachments->foo.doc->Open->Save File [CORRECT]

Several bugs are related to the file picker and filetypes (e.g. bug 509379 and friends), but none seem to deal with this particular problem.

Reproducible: Always
For some odd reason, the very same search I used yesterday to find related bugs found more today.

This bug is a duplicate of bug 414865 (and others).
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 414865
You need to log in before you can comment on or make changes to this bug.