Closed Bug 540861 Opened 11 years ago Closed 11 years ago

Javascript error from the the Error Console: Error: Too much recursion

Categories

(Firefox :: General, defect)

x86
macOS
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 543100

People

(Reporter: abdels, Unassigned)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2) Gecko/20100105 Firefox/3.6
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2) Gecko/20100105 Firefox/3.6

The attached javascript/page does not work in the following:

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2) Gecko/20100105 Firefox/3.6

It displays in the Error Console: "Error: too much recursion". But works fine in the previous version and in the following:

Installed 3.6b1 on Ubuntu and works fine.

Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.2b1) Gecko/20091014
Firefox/3.6b1

Installed 3.6RC1 on windows and works fine.

Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.2) Gecko/20100105
Firefox/3.6 (.NET CLR 3.5.30729)


Reproducible: Always

Steps to Reproduce:
1. Load the attached page.
2. Open the Error Console
3. Click on the "Error" tab.
 
Actual Results:  
Error: too much recursion

Expected Results:  
No error in the Error Console.

See the page attached.
This script should not display "Error: too much recursion". As there is no recursion.
Can this be looked at? It's a regression over FF3.5, where the same website that we discovered the problem in (sample script provided by Abdel, internal protected website) worked w/o any problems.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 543100
You need to log in before you can comment on or make changes to this bug.