If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Options|Rewrap doesn't work on the Mac

VERIFIED FIXED in mozilla0.9.1

Status

MailNews Core
Composition
P3
normal
VERIFIED FIXED
17 years ago
9 years ago

People

(Reporter: Ninoschka Baca, Assigned: Kathleen Brade)

Tracking

Trunk
mozilla0.9.1
PowerPC
Mac System 9.x

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Build 2000-09-21-04M18: Mac 9.04

Overview: In plain text mode, select a message, select the Reply button, select
Options|Rewrap and it just hangs on the Mac.

On NT4 and Linux it behaves differently but these problems are reported in bug#
51799.
(Reporter)

Comment 1

17 years ago
Setting to Major because the application should not hang/crash.
Severity: normal → major
Keywords: crash
QA Contact: esther → nbaca
Summary: Options|Rewrape hangs on the Mac → Options|Rewrap hangs on the Mac
I can reproduce this problem with the last build. Kind of annoying...
Status: NEW → ASSIGNED
OS: All
Target Milestone: --- → mozilla0.9

Comment 3

17 years ago
changing milestone to unknown.  It will get changed back when we figure out what
milestone to put this bug in.
Target Milestone: mozilla0.9 → ---

Updated

17 years ago
Keywords: crash → freeze

Updated

17 years ago
Keywords: freeze → hang
I don't see any hang or crash. However, rewrap doesn't seem to do anything on Mac!!!
reassign to akkana...
Assignee: ducarroz → akkana
Severity: major → normal
Status: ASSIGNED → NEW
Keywords: hang
OS: All → Mac System 9.x
Summary: Options|Rewrap hangs on the Mac → Options|Rewrap doesn't work on the Mac

Comment 6

17 years ago
It doesn't do anything for you?  Did you have quoted text selected?

It does rewrap for me, but it has a bug: it keeps the quote characters ("> ")
even after wrapping, so
> one
> two
will rewrap to 
> one > two

I'll look at it.
Status: NEW → ASSIGNED

Updated

17 years ago
Target Milestone: --- → mozilla1.0

Comment 7

17 years ago
Oh, I see.  Rewrap first converts the selection (or the whole document, if
selection is collapsed) to a string, then rewraps the string.  But it doesn't
specify newline type in the output flags used to generate the string, and
default is platform specific.  But then the rewrapping code was looking for dom
newlines rather than all newline formats.

I have a patch which explicitly specifies LF/DOM line breaks.  In addition, I've
added a check to make sure (in debug builds only) that there aren't any CRs
there (because if there are, there's a bug somewhere else in the code and I need
to know about it); and to default the wrap column to 72 if none is specified
(because rewrapping to no wrap column makes no sense, and it's confusing to have
it do nothing); and, finally, to set the RespectNewlines flag to true instead of
false when Rewrap is called, because that seems more reasonable.

This needs testing on a mac!  My mac can't build right now, so I'll need some
help from a mac person to test this.  Maybe J-F, since it affects mail compose
most, or maybe Simon, since he'll probably eventually be the one I'll ask for an
sr on this code.  It can be tested either in the plaintext editor (where rewrap
is in the debug menu) or in plaintext mail compose.
Whiteboard: FIX IN HAND; needs mac testing

Comment 8

17 years ago
Created attachment 31673 [details] [diff] [review]
Fix

Updated

17 years ago
Target Milestone: mozilla1.0 → mozilla0.9.1
(Assignee)

Comment 9

17 years ago
r=brade
Whiteboard: FIX IN HAND; needs mac testing → FIX IN HAND

Comment 10

17 years ago
Kathy noticed that in nsInternetCiter.cpp the PR_Unichar should be PRUnichar,
and her review was naturally contingent upon that fix change.

Simon, when you get a chance, could you sr this bug?  Thanks!
Whiteboard: FIX IN HAND → FIX IN HAND, needs sr

Comment 11

17 years ago
Passing to Kathy and cc'ing Kin.  Kin sr'ed this, and I was hoping to check it
in today before I left, but the tree is closed.  Hope one of you can check it in
for me.  Thanks!
Assignee: akkana → brade
Status: ASSIGNED → NEW
(Assignee)

Comment 12

17 years ago
fix checked in
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Whiteboard: FIX IN HAND, needs sr
(Reporter)

Comment 13

17 years ago
Build 2001-05-17-04: Mac 9.04
Verified Fixed. I replied to a message, type some text and selected 
Options|Rewrap and it does appear to allign the text better.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.