Closed Bug 540905 Opened 10 years ago Closed 10 years ago

Problem with contact list that includes another contact list

Categories

(Thunderbird :: Address Book, defect)

x86
Windows Vista
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 542947

People

(Reporter: psrodh, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; es-ES; rv:1.9.1.6) Gecko/20091201 Firefox/3.5.6 GTB6 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; es-ES; rv:1.9.1.7) Gecko/20100111 Thunderbird/3.0.1

Suppose a contact list (say "listA", with description "List A") contains, apart from regular contacts, another list (say "listB", with description "List B"). Before 3.0, when trying to send mail to listA, it expanded to all the regular contacts of listA plus all the regular contacts of listB, i.e. the mail was sent to a comma-separated list of ALL the contacts in both listA and listB. As of Thunderbird 3.0, it tries to send the mail to a comma-separated list of the contacts in listA plus a contact called "listB", which, apart from noexistent, is not correctly formed, and thus is rejected by mail servers. 

Reproducible: Always

Steps to Reproduce:
1. create a first list with some contacts
2. create a second list with some contacts and add the first list to this second list
3. send mail to the second list
Actual Results:  
The server complains about a bad destination.

Expected Results:  
The mail should have been sent to all the regular contacts in the first list and all the regular contacts in the second list (as it happened in Thunderbird 2)

This is not the same as Bug 40301, which was a very old problem related with the fact itself of creating a list inside a list. This has appeared in 3.0
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.7) Gecko/20100111 Lightning/1.0b1 Thunderbird/3.0.1

I had this problem as well.  Mine was run on x386 WinXP.

Same reproduction steps:
1. Create <SubList>=abc@domainX
2. Create <ListCover>=bcd@domainY;SubList
3. Compose & send mail to ListCover

TB interpret <SubList> as <SubList@defaultdomain> instead of expanding it.
Sorry, mine was running on x86, not 386
see bug 542947 comment 7
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 542947
You need to log in before you can comment on or make changes to this bug.