[1.9.1 branch] crash [@ JS_dtobasestr] opening or sending an email EXCEPTION_FLT_INVALID_OPERATION

RESOLVED WORKSFORME

Status

()

Core
JavaScript Engine
--
critical
RESOLVED WORKSFORME
8 years ago
6 years ago

People

(Reporter: wsmwk, Unassigned)

Tracking

({crash, topcrash})

1.9.1 Branch
x86
All
crash, topcrash
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(status1.9.2 unaffected, blocking1.9.1 needed, status1.9.1 wanted)

Details

(Whiteboard: [crashkill][TB3topcrash][tb30xwants], crash signature)

(Reporter)

Description

8 years ago
crash [@ JS_dtobasestr] opening or sending an email

top 10 crash for TB 3.0.0 and 3.0.1
(but not for FF and seamonkey)

most common commeonts in both thunderbird and seamonkey are about opening, sending, getting email, or detaching file from email

bp-211bde8d-849c-49b9-8234-4fdb52100119 Thunderbird 3.0
Openning a message.
0	js3250.dll	JS_dtobasestr	 js/src/jsdtoa.cpp:378
1	js3250.dll	num_toString	js/src/jsnum.cpp:384
2	js3250.dll	js_Interpret	js/src/jsinterp.cpp:5147
3	js3250.dll	js_Invoke	js/src/jsinterp.cpp:1394
4	thunderbird.exe	nsXPCWrappedJSClass::CallMethod	js/src/xpconnect/src/xpcwrappedjsclass.cpp:1697
5	thunderbird.exe	nsXPCWrappedJS::CallMethod	js/src/xpconnect/src/xpcwrappedjs.cpp:569
6	xpcom_core.dll	PrepareAndDispatch	xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp:114
7	xpcom_core.dll	SharedStub	xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp:141
8	thunderbird.exe	nsMsgStatusFeedback::OnStateChange	mailnews/base/src/nsMsgStatusFeedback.cpp:171 


bp-e5cd7942-bfa8-4bb2-833e-afa242091230 Seamonkey 2.0.1
0	js3250.dll	JS_dtobasestr	 js/src/jsdtoa.cpp:378
1	js3250.dll	num_toString	js/src/jsnum.cpp:384
2	js3250.dll	js_Interpret	js/src/jsinterp.cpp:5147
3	js3250.dll	js_Invoke	js/src/jsinterp.cpp:1394
4	seamonkey.exe	nsXPCWrappedJSClass::CallMethod	js/src/xpconnect/src/xpcwrappedjsclass.cpp:1697
5	seamonkey.exe	nsXPCWrappedJS::CallMethod	js/src/xpconnect/src/xpcwrappedjs.cpp:569 

bp-79170910-f3e1-4bbe-8ffc-c4c072100120 FF 3.6
0	js3250.dll	JS_dtobasestr	 js/src/jsdtoa.cpp:378
1	js3250.dll	num_toString	js/src/jsnum.cpp:412
2	js3250.dll	js_Interpret	js/src/jsops.cpp:2208
3	js3250.dll	js_Execute	js/src/jsinterp.cpp:1601
4	js3250.dll	JS_EvaluateUCScriptForPrincipals	js/src/jsapi.cpp:5070
5	xul.dll	nsJSContext::EvaluateString	dom/base/nsJSEnvironment.cpp:1713
6	xul.dll	nsScriptLoader::EvaluateScript	content/base/src/nsScriptLoader.cpp:711
Flags: blocking-thunderbird3.1?

Comment 1

8 years ago
Crash Reason	EXCEPTION_FLT_INVALID_OPERATION

374 if (dval(d) < 0.0
375 #if defined(XP_WIN) || defined(XP_OS2)
376 && !((word0(d) & Exp_mask) == Exp_mask && ((word0(d) & Frac_mask) || word1(d))) /* Visual C++ doesn't know how to compare against NaN */
377 #endif
Assignee: nobody → general
Component: General → JavaScript Engine
Flags: blocking-thunderbird3.1?
Product: Thunderbird → Core
QA Contact: general → general
Summary: crash [@ JS_dtobasestr] opening or sending an email → crash [@ JS_dtobasestr] opening or sending an email EXCEPTION_FLT_INVALID_OPERATION
Version: unspecified → 1.9.1 Branch
This looks like bug 533035 yet again to me.

Comment 3

8 years ago
yeah, it sounded like that to me too. but afaict you guys haven't managed to get it fixed for 1.9.2, let alone 1.9.1, please do add it to the backlog :)
That bug is definitely on the backlog. I'm duping this one for now, it can be reopened if it persists after that one.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 533035
Reopening based on Mike's bug 533035 comment 126 as the "separate" bug to get this back ported to 1.9.1.

Nominating for blocking 1.9.1 as this has been consistently in the 5 top crashes for Thunderbird 3.0.x since we released TB 3 and there is already a solution out there even if it needs porting a little bit.

It looks like bug 538642 may be sufficient to "fix" this crash, but is that really the case or do we need some of the code from bug 533035 as well?
Status: RESOLVED → REOPENED
blocking1.9.1: --- → ?
Depends on: 533035, 538642
Resolution: DUPLICATE → ---
Summary: crash [@ JS_dtobasestr] opening or sending an email EXCEPTION_FLT_INVALID_OPERATION → [1.9.1 branch] crash [@ JS_dtobasestr] opening or sending an email EXCEPTION_FLT_INVALID_OPERATION
Whiteboard: [crashkill][TB3topcrash][tb30xwants]
The patches from bug 538642 apply on top of the patch from bug 533035. Both are necessary to actually fix the bug.
Not going hold the next releases on this but will prioritize patch approval as if it's blocking. Sounds like you know the fix, just need a backported combined patch added to this bug.
blocking1.9.1: ? → needed
status1.9.1: --- → wanted
status1.9.2: --- → unaffected
(Reporter)

Comment 8

8 years ago
(In reply to comment #3)
> yeah, it sounded like that to me too. but afaict you guys haven't managed to
> get it fixed for 1.9.2, let alone 1.9.1

now "fixed" on 1.9.2 per bug 538642 comment 34
Crash Signature: [@ JS_dtobasestr]

Comment 9

6 years ago
Does this affect any builds after TB 3.1.x, i.e., Gecko versions > 1.9.2?
If not, this should probably be closed as 1.9.1 isn't supported any more.
Nothing found in the last 4 weeks for Fx, SM, and TB on any branch.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.