:first-letter pseudo element does not render right

VERIFIED FIXED

Status

()

Core
Layout
P3
normal
VERIFIED FIXED
18 years ago
15 years ago

People

(Reporter: Frank Tang, Assigned: Shanjian Li)

Tracking

({css1, testcase})

Trunk
css1, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
somehow from the second paragraph the line start in wrong position.
See test cases attached later.
(Reporter)

Comment 1

18 years ago
Created attachment 15477 [details]
:first-letter pseudo-element problem test case CSS2 5.12.1
(Reporter)

Comment 2

18 years ago
The first and second paragraph is ok. But the third paragraph 'A ... is display
not from the beginning of the line.

I will report a sperate bug about the punctuation mark and :first-letter in
other bug.

See CSS2 Page 67 (PDF version) or section 5.12.2 The :first-letter
pseudo-element for detail. This is also in CSS1.
(Reporter)

Comment 3

18 years ago
The punctuation mark problem have been file as 54101

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → Future
(Reporter)

Comment 4

18 years ago
This wrong position problem does not happen on the Mac 2000092711 build. But it
does happen on my local Linux build.
(Reporter)

Comment 5

18 years ago
problem on the Linux 2000092710 build and window 2000092608 build
Keywords: css1
Upon managerial request, adding the "testcase" keyword to 84 open layout bugs that
do not have the "testcase" keyword and yet have an attachement with the word
"test" in the description field. Apologies for any mistakes.
Keywords: testcase

Comment 7

18 years ago
:first-letter seems not to support separate text-decoration at all. Inherests
it, even if unwanted, but can't be separately applied to :first-letter itself.
Tested in Win-95 only.
(Reporter)

Comment 8

18 years ago
remove future
Target Milestone: Future → ---
(Reporter)

Comment 9

17 years ago
Mark it as moz1.0 for now.
Target Milestone: --- → mozilla1.0
(Reporter)

Comment 10

17 years ago
erik resign. reassign all his bug to ftang for now.
Assignee: erik → ftang
Status: ASSIGNED → NEW
(Reporter)

Comment 11

17 years ago
IS this still a problem ? reassign to shanjian and remove Target milestone
Assignee: ftang → shanjian
Target Milestone: mozilla1.0 → ---
(Assignee)

Comment 12

17 years ago
The reported problem is not seen on my current windows build. But I saw another problem with 
the attached testcase. The italic style of first-letter overlapped with normal text. I am not 
sure if we already have one bug for that. 
(Reporter)

Comment 13

17 years ago
I cannot reproduce the origional problem , same as shanjian. Mark this bug as 
FIXED.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 14

17 years ago
Marking verified per last comments.
Status: RESOLVED → VERIFIED

Comment 15

15 years ago
This problem still occurs in Mozilla 1.3b... at least as I understand the bug.
If your browser window is wide enough for each paragraph to fit on one line,
then starting with the third paragraph, each successive paragraph is indented
further and further toward the right. By the time you get to the last paragraph,
the indent is about 3 inches.

I'll attach a screencap in a moment.

Comment 16

15 years ago
Created attachment 116572 [details]
Screen cap showing improper indentation/wrapping

Note that if the paragraphs are longer or if your browser window is narrower
(so that each paragraph has at least two lines), the paragraphs move back to
the left where they belong.
You need to log in before you can comment on or make changes to this bug.