Closed Bug 541005 Opened 10 years ago Closed 7 years ago

Determine which locales actively develop in which branches

Categories

(Mozilla Localizations :: Infrastructure, defect)

x86
All
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 713159

People

(Reporter: joduinn, Unassigned)

Details

Summary: RelEng generate nightly l10n updates for localizers to use
during localization. Each l10n nightly requires to create 70+ repacks, for
each of 7 OS, and then generate updates for all of these. This load is increasing as we add locales, and add new OS.

We initially provided these updates on mozilla-central, to help active
localisation by some localizers. However, we have since been asked to also
provide updates on mozilla-1.9.2 and also lorentz branches, because
different localizers focus their work on different branches. This is a
lot of additional compute work, which only makes sense to do if there are
people actually using those builds on all those branches.

From email and meetings, Axel/Seth confirmed localizers typically work
in one specific branch (based on their preference), but typically they
are not actively working in *all* branches at the same time. Therefore
no need to do nightly l10n updates for every locale on every branch; a localizer
only need nightly l10n updates for the branch they are working on.

This bug is to track figuring out which localizers are working on which branches
and get that information into a checkedin file somewhere in that branch. If we can find some metrics data to help inform decision on this, we
will add here, but the final call is up to l10n community to decide what
locales go in this checkedin file on each branch. RelEng would then use that checkedin file in each branch when generating nightly l10n updates for that branch.
http://groups.google.com/group/mozilla.dev.planning/browse_frm/thread/b844ccfce7be0576# is the thread on what we want from nightlies. The discussion should happen there.

Not sure if this bug serves any real purpose, it'll get resolved by changing all-locales on a few places.
Resolving as dupe of bug 713159, which has appropriate dependencies set, too.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 713159
You need to log in before you can comment on or make changes to this bug.