Double-click in an input box on a web page no longer offers choices from history

RESOLVED INVALID

Status

()

--
minor
RESOLVED INVALID
9 years ago
7 years ago

People

(Reporter: bcraigie, Unassigned)

Tracking

3.6 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Caused by Google Toolbar], URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7 GTB6 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7 GTB6 (.NET CLR 3.5.30729)

It used to be until recently that when visiting a web page that I've been to before and have filled in values on before, that double-clicking the input box would offer up the list of previously entered values.

However, now *sometimes* (depends which web page it is) you have to type the first character before it offers what was remembered beginning with that character.  A sample page where this happens is http://www.travelinescotland.com/timetableplanner/serviceSelect.do and instructions to replicate are listed below.



Reproducible: Sometimes

Steps to Reproduce:
1. Visit http://www.travelinescotland.com/timetableplanner/serviceSelect.do
2. Enter 191 in the service number (could be any number but I know this one exists)
3. Click "Look up timetable".
4. This lists several bus routes.  Now simply click "New Timetable..."
5. Double-click in the Service Number input box.  Nothing happens.  Now enter 1 into that box.  191 appears.


Actual Results:  
Nothing happens on the double-click

Expected Results:  
previously entered items should appear without having to resort to keyboard presses, like it does normally.

Not sure why this site causes this effect, but it is not the only site.  There are many others like it.
Reporter, are you still seeing this issue with Firefox 3.6.13 or later in safe mode? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles

You can also try to reproduce in Firefox 4 Beta 8 or later, there are many improvements in the new version, http://www.mozilla.com/en-US/firefox/all-beta.html
Whiteboard: [CLOSEME 2011-1-30]
(Reporter)

Comment 2

8 years ago
Yes, it is still a problem, on the majority of sites.  It is really annoying.

Warmest Regards,

Brian

Updated

8 years ago
Whiteboard: [CLOSEME 2011-1-30]
Version: unspecified → 3.6 Branch
(Reporter)

Comment 3

8 years ago
This appears to be caused by the Google Toolbar.  See http://www.google.com/support/forum/p/Toolbar/thread?tid=1078671bc0d271b5&hl=en

They have been working on it for some time (at least since Dec 2009).  A vote for it at http://www.google.com/support/toolbar/bin/static.py?hl=en&page=known_issues.cs (Multiple Usernames not suggested when toolbar enabled) might jolly things along.

Although the bug refers to usernames, any remembered input box would appear to be affected.

Brian


Brian

Comment 4

7 years ago
Reporter -> Are you still experiencing this issue? Have you confirmed that the issue is caused by Google Toolbar?
(Reporter)

Comment 5

7 years ago
Hi Tim, yes it was caused by the Google toolbar.  Once I uninstalled the google toolbar, the problem disappeared. :-)

Brian

Comment 6

7 years ago
Thanks for the update Brian!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Component: General → Extension Compatibility
QA Contact: general → extension.compatibility
Resolution: --- → INVALID
Whiteboard: [Caused by Google Toolbar]
You need to log in before you can comment on or make changes to this bug.