Thunderbird won't quit if start gpg gent automatically started for user

VERIFIED INVALID

Status

Thunderbird
General
VERIFIED INVALID
8 years ago
8 years ago

People

(Reporter: webmaster, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.7) Gecko/20100111 Lightning/1.0b1 Thunderbird/3.0.1

If the gpg-agent is activated for auto-start thunderbird will not quit - the gui goes away but the app doesn't end. If gpg-agent is stopped thunderbord will quit - and strangely enough, if started later, thunderbird will still start/stop.

Reproducible: Always

Steps to Reproduce:
1. Auto-activate start-gpg-agent for  a user
2. Login
3. start thunderbord
4. Quit Thunderbird
Actual Results:  
Gui disappears, App doesn't

Expected Results:  
Left the building
Are you using enigmail ?
(Reporter)

Comment 2

8 years ago
Correction! Shortly after Thunderbird starts a second gpg-agent process is started, as soon as this is started Thunderbird will no longer exit cleanly. If the second gpg-agent process is ended, Thunderbird will exit.
I am using OpenPGP(Eingmail)

Comment 3

8 years ago
known issue. See https://www.mozdev.org/bugs/show_bug.cgi?id=22072

Resolutions:
a) use a nightly build of Enigmail
b) upgrade to MacGPG2 v2.0.14 RC2

Set to invalid because it's not related to Thunderbird.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.