If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

clicking a tab does nothing while weave is syncing

RESOLVED WORKSFORME

Status

Cloud Services
General
RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: Evan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

8.86 KB, text/plain
Details
(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7 (.NET CLR 3.5.30729)

while weave is syncing, I cannot click on a tab to change to that tab.

Reproducible: Sometimes

Steps to Reproduce:
1. Open Firefox with Weave enabled
2. Open up multiple tabs
3. Click on one of those tabs, as if to open it
Actual Results:  
Given that Weave is attempting to sync, nothing will happen at step 3.

Expected Results:  
Step 3 should make Firefox switch to the tab clicked on.

Using Weave Sync 1.0rc2. I currently have it disabled, and everything functions as normal. I think my school's web filter may be blocking the connection to the server, but weave still persists to try to connect.
(Reporter)

Comment 1

8 years ago
Created attachment 422778 [details]
Activity log

Comment 2

8 years ago
The log seems to indicate something wrong is going on in the network.. but it's not the network throwing an exception; no Error.stack property. So something must be throwing a plain value...
(Reporter)

Comment 3

8 years ago
Well, it looks like the sync server is blocked (using FortiGuard Web Filtering) under "Freeware Downloads". Could that have something to do with it?(In reply to comment #2)
> The log seems to indicate something wrong is going on in the network.. but it's
> not the network throwing an exception; no Error.stack property. So something
> must be throwing a plain value...
(Reporter)

Comment 4

8 years ago
I got an e-mail back after I requested that they re-examine the category, and they changed it to "Information Technology", which is not blocked.

That still does not resolve the problem of not being able to change tabs while Weave is trying to connect though.
(Reporter)

Updated

8 years ago
Severity: major → normal
(Reporter)

Comment 5

8 years ago
Well, that e-mail lied, but, either way, I'm at school now, and I'm able to sync. Also, when it is syncing, I am, in fact, able to change tabs.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

8 years ago
I stand corrected. I think it happens when it's trying to connect, and failing for one reason or another. The weave icon in the status bar is spinning, but it only shows my username. It doesn't say "Weave: Syncing bookmarks" or anything like that.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Updated

7 years ago
Component: Needs Triage → General
QA Contact: needstriage → general
I can't repro this, but I could a long time ago, so calling this WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.