New Hide Menu Bar option is erratic. Does not always work, doesn't work on restart.

RESOLVED DUPLICATE of bug 526460

Status

()

Firefox
Menus
RESOLVED DUPLICATE of bug 526460
9 years ago
9 years ago

People

(Reporter: shey, Unassigned)

Tracking

3.6 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [DUPEME])

Attachments

(1 attachment)

11.29 KB, application/rdf+xml
Details
(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6

Left click Menu Bar, uncheck/check Menu bar, displaying erratic behavior.  Menu bar not hidden on restart.  Does not always hide and being back the menu bar like it's supposed to in the same session.


Reproducible: Always

Steps to Reproduce:
1.Left click Menu Bar
2.Uncheck Menu bar
3.restart Firefox
(Reporter)

Comment 1

9 years ago
Sorry, all the above should be RIGHT-CLICK, not left!!!
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.3a1pre) Gecko/20100121 Minefield/3.7a1pre

This works fine for me.
Whiteboard: [DUPEME]
Shey, can you please attach the localstore.rdf from your profile on that bug? See http://support.mozilla.com/en-US/kb/Profiles for its location.
Version: unspecified → 3.6 Branch

Comment 4

9 years ago
When I put bookmarks on the menu bar, then uncheck Menu Bar from View->Toolbars, the menu bar disappears. But when I restart Firefox, the menu bar is visible, even though it is unchecked, and checking/unchecking does nothing. If Firefox is started with the menu bar checked and visible in the previous session, then I can toggle it in the current session.

This may have something to do with what Shey is saying.
K T, can you please follow my advise from comment 3 please? That would be great.

Comment 6

9 years ago
Confirmed same behavior.

Windows XP SP3 with Firefox 3.6 (upgraded from 3.5.7).  Attaching localstore.rdf.

Comment 7

9 years ago
Created attachment 423371 [details]
localstore.rdf
Ok, I believe we can safely dupe it against bug 526460 now. It has already been identified and fixed for Firefox 3.7a1 and will hopefully get approval for Firefox 3.6.1.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 526460
You need to log in before you can comment on or make changes to this bug.