cairo-qt build of Fennec crashed in cairo-qpainter-surface.cpp

RESOLVED DUPLICATE of bug 536765

Status

()

RESOLVED DUPLICATE of bug 536765
9 years ago
9 years ago

People

(Reporter: carl.wong, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
Created attachment 422804 [details] [diff] [review]
patch to fix crash in _cairo_qpainter_surface_flush fuction.

I have built Fennec with the Qt4.6 and I encountered a crashed in cairo-qpainter-surface.cpp. A patch is attached.  To reproduce this problem, do the following:

 1) build fennec with the option "--enable-default-toolkit=cairo-qt"
 2) Just swipe to your right to get to the "Tab" pane.  

You should see a seg. fault and if you run it under the debugger, you will see it is crashing in cairo-qpointer-surface.cpp.

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 536765
You need to log in before you can comment on or make changes to this bug.