status bar's background doesn't get set, using Lightweight Themes / Personas with "Windows Classic" window-style

RESOLVED FIXED in mozilla1.9.3a1

Status

()

RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: dholbert, Assigned: dao)

Tracking

1.9.2 Branch
mozilla1.9.3a1
x86
Windows XP
Points:
---

Firefox Tracking Flags

(blocking1.9.2 -, status1.9.2 .5-fixed)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

9 years ago
STEPS TO REPRODUCE:
 1. Right-click Desktop & choose "Properties", and go to "Appearance" tab
 2. In "Windows and buttons" dropdown, choose "Windows Classic style"
 3. Run Firefox 3.6 or newer.
 4. Visit URL ( http://www.getpersonas.com/ )
 5. Mouseover some personas, and inspect your status bar.

EXPECTED RESULTS:
 Status bar should change to match the moused-over persona's theme.

ACTUAL RESULTS:
 Status bar's *text* changes color, but background remains the same (gray), except for a tiny colored vertical bar at the rightmost edge of the window. (with the color matching the Persona) Also: if you have any extensions installed that add status-bar icons (e.g. Greasemonkey, Stylish) you'll get additional vertical bars between those icons.

If I switch to "Windows XP style" Windows and buttons, the bug goes away.

OPERATING SYSTEM: Windows XP SP3, up-to-date
BROWSER: Firefox 3.6 release version, as well as latest trunk nightly.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a1pre) Gecko/20100120 Minefield/3.7a1pre (.NET CLR 3.5.30729)
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6 (.NET CLR 3.5.30729)
(Reporter)

Updated

9 years ago
Summary: Status bar background doesn't change, using Lightweight Themes / Personas with "Windows Classic" window-style → status bar's background doesn't get set, using Lightweight Themes / Personas with "Windows Classic" window-style
(Reporter)

Comment 1

9 years ago
Posted image screenshot of bug
(Reporter)

Updated

9 years ago
blocking1.9.2: --- → ?
(Reporter)

Comment 2

9 years ago
Note that this is particularly egregious because it's affects the Firefox 3.6 firstrun page, which everyone sees when they install or upgrade:
  http://www.mozilla.com/en-US/firefox/3.6/firstrun/

That page has 6 personas featured prominently in the middle, which style the browser -- and trigger this bug -- when the user mouses over them.
(Assignee)

Updated

9 years ago
Assignee: nobody → dao
Component: Theme → Themes
Product: Firefox → Toolkit
QA Contact: theme → themes
(Assignee)

Updated

9 years ago
Version: Trunk → 1.9.2 Branch
(Assignee)

Comment 3

9 years ago
Posted patch patchSplinter Review
Attachment #422956 - Flags: review?(rflint)
Attachment #422956 - Flags: approval1.9.2.1?
(Reporter)

Comment 4

9 years ago
I think Version --> Trunk is correct -- AIUI, it's only supposed to be set to a branch for branch-only issues.  (and this bug isn't branch-only)

Thanks for the quick patching!
Version: 1.9.2 Branch → Trunk
(Assignee)

Comment 5

9 years ago
(In reply to comment #4)
> I think Version --> Trunk is correct -- AIUI, it's only supposed to be set to a
> branch for branch-only issues.

This would make the field pretty much useless, since the vast majority of all bugs exist on trunk. I set it to the branch that the bug was first shipped on, in order to remind me on which branches the fix may land.
Version: Trunk → 1.9.2 Branch
Attachment #422956 - Flags: review?(rflint) → review+
(Assignee)

Comment 6

9 years ago
http://hg.mozilla.org/mozilla-central/rev/f309486c41f3
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.3a1
blocking1.9.2: ? → -
status1.9.2: --- → wanted
(Assignee)

Updated

9 years ago
Duplicate of this bug: 550404
Attachment #422956 - Flags: approval1.9.2.2? → approval1.9.2.3?

Comment 8

9 years ago
OK, so I can see the patch by Dao.
How do I install it?
The bug persists in FF3.6.3
(see http://drop.io/FF363StatusBarBox#)

Comment 9

9 years ago
Can I manually run the DIFF patch proposed here?
(Assignee)

Comment 10

9 years ago
The patch is waiting for approval for Firefox 3.6.*.
(Reporter)

Comment 11

9 years ago
Suburp: You can't apply the patch yourself without doing a custom build of Firefox, which is a somewhat-serious undertaking and is beyond the scope of this bug.

You probably want to just wait until the patch gets included in a Firefox release, at which point you'll get an automatic update.  As Dao said, it's currently awaiting approval to be included in Gecko 1.9.2.4 / Firefox 3.6.4.

Comment 12

9 years ago
Ah, I see, thanks for the quick replies. I just thought I had forgotten to do something on my side.
Thx!
(Assignee)

Updated

9 years ago
Duplicate of this bug: 559900
(Assignee)

Updated

9 years ago
Attachment #422956 - Flags: approval1.9.2.5?

Comment 14

9 years ago
Comment on attachment 422956 [details] [diff] [review]
patch

a=LegNeato for 1.9.2.5. Please ONLY land this on mozilla-1.9.2 default, as we
are still working on 1.9.2.4 on the relbranch
Attachment #422956 - Flags: approval1.9.2.5?
Attachment #422956 - Flags: approval1.9.2.5+
Attachment #422956 - Flags: approval1.9.2.4?
(Assignee)

Updated

9 years ago
Keywords: checkin-needed
(Assignee)

Comment 15

9 years ago
http://hg.mozilla.org/releases/mozilla-1.9.2/rev/b506cd49c915
status1.9.2: wanted → .5-fixed
Keywords: checkin-needed

Comment 16

9 years ago
Just to confirm, this has not been landed on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.4) Gecko/20100611 Firefox/3.6.4 , correct?
(Reporter)

Comment 17

9 years ago
Correct -- per comment 14, it was approved for Gecko 1.9.2.5  (Firefox 3.6.5).
(Reporter)

Comment 18

9 years ago
(In reply to comment #16)
> Just to confirm, this has not been landed

One clarification, though -- this *has* been landed on Gecko 1.9.2 (the codebase that Firefox 3.6) is built from (in comment 15).  It just landed *after* the code freeze + branch for Firefox 3.6.4.
(Reporter)

Comment 19

9 years ago
s/that Firefox 3.6) is built from/that Firefox 3.6 is built from)/
You need to log in before you can comment on or make changes to this bug.