Cannot migrate from firefox 3.5 to 3.6

VERIFIED INVALID

Status

()

Firefox
Extension Compatibility
--
critical
VERIFIED INVALID
8 years ago
8 years ago

People

(Reporter: Steffen Michalke, Unassigned)

Tracking

3.6 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [caused by keyconfig])

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7

I defined a new profile for FF 3.6 (firefox -P, FF 3.5), then copied the content of the profile directory of my FF 3.5 installation to it. Then I ran FF 3.6 with that profile. Worked fine.

Then I closed and restarted FF 3.6. Now I got the error messages:
GetCharPref('id') failed
GetCharPref('version') failed

FF died immediately.


Reproducible: Always

Steps to Reproduce:
1. Set up a new profile, say 3.6, with FF 3.5.
2. Copy the 3.5-profile to the new directory.
3. Start FF 3.6 with -P 3.6.
4. Shutdown the browser.
5. Start FF 3.6 as in 3.)

Actual Results:  
FF does not start.

Expected Results:  
FF should run with the copied profile.
try safe mode, could be some add-on is not compatible or causing issues.

http://support.mozilla.com/kb/Safe+Mode
also, it's possible you did not copy the profile correctly.
did you copy it while both instances of the browser were closed?
(Reporter)

Comment 3

8 years ago
Thank you a lot, safe mode works fine. I will have to try the extensions one by one.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

8 years ago
OK, for the record, keyconfig breaks FF 3.6. Everything else works very fine here.
thanks for getting back to us. you can report to the extension developer if you desire.
Status: RESOLVED → VERIFIED
Component: General → Extension Compatibility
QA Contact: general → extension.compatibility
Whiteboard: [caused by keyconfig]
Version: unspecified → 3.6 Branch
You need to log in before you can comment on or make changes to this bug.