Closed Bug 541309 Opened 10 years ago Closed 10 years ago

The mouse wheel no longer zooms in on the stock charts on Google Finance.

Categories

(Core :: Widget: Win32, defect)

x86
Windows Vista
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla1.9.3a1

People

(Reporter: drew, Assigned: masayuki)

References

Details

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6 (.NET CLR 3.5.30729)

The mouse wheel no longer zooms in/out on the stock charts on Google Finance.

Steps to Reproduce:
1. Navigate to Google Finance and click on a stock (http://www.google.com/finance?q=INDEXDJX:.DJI).
2. Try to use the mouse wheel to zoom.

Regression Range: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=b8cbe3c9542b&tochange=ca23d3b5a999

Bug Introduced (flash does not load at all on Google Finance):
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2a1pre) Gecko/20090628 Minefield/3.6a1pre (.NET CLR 3.5.30729)
Built from http://hg.mozilla.org/mozilla-central/rev/ca23d3b5a999

Bug Not Yet Introduced:
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2a1pre) Gecko/20090627 Minefield/3.6a1pre (.NET CLR 3.5.30729)
Built from http://hg.mozilla.org/mozilla-central/rev/b8cbe3c9542b
I tested on Win7. We send WM_MOUSEWHEEL message to the plug-in correctly, but when it's not focused, it doesn't process the message (our wndproc is called by the plug-in's wndproc).

Probably, this is Flash Player's specification or its application's.

I think that this should be marked as INVA.
However, Google Chrome 4.0.249.78  does.
(In reply to comment #2)
> However, Google Chrome 4.0.249.78  does.

I tested on Google Chrome 3, but it always doesn't send the wheel messages if the plug-in isn't focused. Is Google Chrome going to change the behavior?
IE8, Opera 10.10 and Safari 4.0.4(531.21.10) on Windows 7 x64 can zoom by mouse wheel as same as Google Chrome 4.0.249.78.
Firefox3.6 and Minefield3.7a1pre can not zoom by mouse wheel.
And Firefox 3.5.7 also does. I don't think this is Flash Player's fault.
(In reply to comment #1)
> when it's not focused, it doesn't process the message (our wndproc is called by
> the plug-in's wndproc).
Why do you talk about an unfocused case? Per STR,
> 1. Navigate to Google Finance and click on a stock
                                ^^^^^^^^^^^^^^^^^^^^
Flash Player should have the focus.
Focus , nofocus of the Flash is no matter.
Even if the caret is in the input box at beside the Google logo.
(In reply to comment #6)
> (In reply to comment #1)
> > when it's not focused, it doesn't process the message (our wndproc is called by
> > the plug-in's wndproc).
> Why do you talk about an unfocused case? Per STR,
> > 1. Navigate to Google Finance and click on a stock
>                                 ^^^^^^^^^^^^^^^^^^^^
> Flash Player should have the focus.

Oh, I cannot reproduce this bug when I set focus to the flash.
Ah, O.K. I can reproduce this bug on another environment, and I confirmed that this bug is fixed by bug 483136's patch.
Assignee: nobody → masayuki
Status: NEW → ASSIGNED
Component: General → Widget: Win32
Product: Firefox → Core
QA Contact: general → win32
Target Milestone: --- → mozilla1.9.3a1
Version: 3.6 Branch → Trunk
Fixed by bug 531341.
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Duplicate of this bug: 542643
Where can I find a nightly which includes this fix?
Duplicate of this bug: 552485
You need to log in before you can comment on or make changes to this bug.