Closed Bug 541370 Opened 13 years ago Closed 13 years ago

Reminder does not update after changing start/end date and snooze already use on the event

Categories

(Calendar :: Alarms, defect)

Lightning 1.0b1
x86
Windows Server 2003
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 360916

People

(Reporter: hernan, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.1.7) Gecko/20100111 Lightning/1.0b1 Thunderbird/3.0.1

When you edit a event changing the start and/or end date and you have a reminder relative to that date (ie. 1 minute before the event starts) then the reminder stay fix in the original time.
The reminder does not update even closing the reminders window or restarting TB.
This only happens if you snooze the event at least once before editing the event
Then only workaround I found is to delete the event and create a new one


Reproducible: Always

Steps to Reproduce:
1.Create a new event with "start date" = today and the hour/minutes just ten minutes ahead, the same for the "end date"
2.Set reminder to "5 minutes before"
3.Save & close
4.After some minutes the reminder appears
5.Snooze the event for 1 minute
6.When the reminder is shown edit the event (with de "details..." link in the reminders window) and change the start date to the next day, Save & close
Actual Results:  
The reminder remains in the reminders window

Expected Results:  
The reminder disappears until the next day (this is what happens if you do NOT snooze the event)
Version: unspecified → Lightning 1.0b1
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 360916
You need to log in before you can comment on or make changes to this bug.