Closed Bug 541374 Opened 10 years ago Closed 4 years ago

Invision Power Board 2.3.6 Rich text editor does not work

Categories

(Core :: DOM: Editor, defect, major)

x86
Windows XP
defect
Not set
major

Tracking

()

RESOLVED INVALID
Tracking Status
blocking1.9.2 --- -
status1.9.2 --- wanted

People

(Reporter: ollittm, Assigned: smaug)

References

()

Details

(Keywords: regression)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6 (.NET CLR 3.5.30729)

Upgrading to firefox 3.6 broke the nexus forum rich text editor and probably invision power board RTE in general. You can select text in the editor but cannot write anything and there is no cursor.

Going back to FF 3.5.7 fixes the issue. 

Reproducible: Always

Steps to Reproduce:
1.Hit new topic button
2.Try to write text
Actual Results:  
Cannot write

Expected Results:  
Can write
Version: unspecified → 3.6 Branch
Same thing happens with W7 RTM x64 and FF 3.6.
Your STR don't work. By following them (on the URL you gave) gives me a "Sorry, you do not have permission to start a topic in this forum".
Yeah, you need to register there to post. In fact their captcha also misbehaves, it doesn't show what you're typing (but works) 

Username "bugzilla" was already taken but I made an account for bugzillatest / bugzilla
And don't forget to check in what position is a switch button at top right of the form - rich text editor or standard.
As I see rich text editor - there is no cursor in form and buttons like bold don,t work
The same reported about forum.kaspersky.com

FF 3.6 Win XP SP3
I'm also seeing this bug at Piriform's message board since updating to 3.6. Workaround for the time being is to switch to standard text editor.

FF3.6, WinXP SP3
I'm having the same issue with http://www.serenitymovie.org/browncoats/forums/index.php?act=idx.  The standard editor works fine.  The issue is only with the rich text editor.  It's not possible to type anything in the comment box when another post has been quoted. It's also not possible to copy and paste the quoted text even though it's possible to highlight everything in the comment box.  The issue wasn't present in FF 3.5.7.  I've tried it on a machine running Win7 x64 and WinXP Pro SP3 x32 with the same results.
From my point of view this is probably a problem with used message board software IPBoard 2.3.6, which reached EndOfLifecyle in the mean time. The newest IPBoard 3.0.5 works fine with Rich Text Editor and FF 3.6. You can prove it with a free demo installation:

http://www.invisionpower.com/products/demo.php 

Best regards Michael
I can confirm this problem. Upgrading to IPB 3.0.5 is not a possibility for us and I am sure it is not going to be for many other IPB boards either. Given that IPB is quite popular software, this looks like a serious regression.

It would be nice to figure out if the issue is due to an IPB bug, so maybe a patch for 2.3.6 can be developed and spread, or if it's due to a regression in Firefox itself.
Anyone, who sees this bug, can help to resolve it by search for regression window: http://quality.mozilla.org/documents-home/bugs-docs/bug-triaging-guidelines/finding-regression-windows
I went back as far as:

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2009/08/2009-08-13-12-mozilla-1.9.2/

Which is the first nightly I see that is 3.6.x. It also has the problem.
(In reply to comment #10)
> I went back as far as:
> 
> http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2009/08/2009-08-13-12-mozilla-1.9.2/
> 
> Which is the first nightly I see that is 3.6.x. It also has the problem.
No, it's not first. Earlier nightlies of 3.6.x is in mozilla-central/ folders e.g. http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2009/08/2009-08-12-04-mozilla-central/
Seems to have broken between 23 March and 27 March 2009. Will try to narrow down more.
This broke between 26 March and 27 March 2009.

WORKS: Built from http://hg.mozilla.org/mozilla-central/rev/85bd18f6b652
BROKEN: Built from http://hg.mozilla.org/mozilla-central/rev/be12595f2d01

Let me know if there's anything more I can do.
Confirming, based on reports, and tweaking summary to indicate that this is problem with IPB 2.3.6
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Invision Power Board Rich text editor does not work → Invision Power Board 2.3.6 Rich text editor does not work
Bug exists on Linux (debian unstable) x64 too. 

I'll try to bisect further to a specific changeset.
The first bad revision is:
changeset:   26607:6b3cc966ef52
user:        Boris Zbarsky <bzbarsky@mit.edu>
date:        Thu Mar 26 14:08:58 2009 -0400
summary:     Bug 148810.  Handle dynamic insertion and append better when table pseudo-frames are involved.  r=bernd, sr=roc.  Also fixes bug 112142, bug 208305, bug 325543, bug 368932, bug 371054, bug 372649, bug 394402, bug 448111.
Hmm.  Loading this page gives me:

###!!! ASSERTION: no frame, see bug #188946: 'frame', file ../../../../mozilla/editor/libeditor/base/nsEditor.cpp, line 4167
###!!! ASSERTION: transaction did not execute properly: '(NS_SUCCEEDED(result))', file ../../../../mozilla/editor/libeditor/base/nsEditor.cpp, line 752

Then I hit the WipeContainingBlock case bug 148810 added, because the table cell with id "ed-0_options-bar" is styled as display:block by the site for some reason (presumably as a broken way of unhiding it).  This causes a reconstruct of the table row containing that cell, which includes the cell containing the iframe the editor is in.

That reconstruct is not a "new" thing.  It could be triggered in all sorts of ways beforebug 148810.  The real issue is that editor is not dealing with it for some reason; not sure whether the asserts above are relevant to that.
OK, trying to click in the editor area throws an NS_ERROR_NOT_INITIALIZED, because the mSelConWeak for the editor in question has a null referent.  So GetSelection throws, which makes GetInlinePropertyBase throw, which makes GetFontFaceState throw, which makes nsFontFaceStateCommand::GetCurrentState throw, which makes nsHTMLDocument::QueryCommandValue throw.
OK, the "no frame" assert also happens in 1.9.1.  The "transaction did not execute properly" assert doesn't seem to.

If in 1.9.1 I set the iframe containing the editor to display:none and then remove that style, like so:

javascript:var myIFrame = document.getElementById("ed-0_iframe"); myIFrame.style.display = "none"; document.body.offsetWidth; myIFrame.style.display = ""; void(0);

then on clicking in the editor I get a while slew of:

###!!! ASSERTION: GetPrimaryFrameFor() called while nsFrameManager is being destroyed!: 'Error', file /Users/bzbarsky/mozilla/1.9.1-branch/mozilla/layout/base/nsFrameManager.cpp, line 340

and there is no caret.  I can type in text, but the "bold" button doesn't work, and trying to use "bold" gives:

WARNING: NS_ENSURE_TRUE(mShell) failed: file /Users/bzbarsky/mozilla/1.9.1-branch/mozilla/layout/generic/nsSelection.cpp, line 2157

That's exactly the behavior I see in 1.9.2, as expected.  So the frame reconstruct is just exposing an editor issue of some sort that already existed in 1.9.1.

The document the QueryCommandValue call is being made on is in fact the current doc of its outer window.  

Is it possible that the editor doesn't properly pick up the presshell of the document changing?
Component: General → Editor
Product: Firefox → Core
QA Contact: general → editor
Version: 3.6 Branch → Trunk
Taking.
Assignee: nobody → Olli.Pettay
blocking1.9.2: --- → ?
blocking1.9.2: ? → -
Would like to get confirmation & look into closing this item. However I have No access to Invision Power Board 2.3.6 - Gian-Carlo, can you provide an update Status for this bug?
Flags: needinfo?(gpascutto)
As comment 22 says, IPB provided a workaround and fixed it in the next update of their software. I no longer have access to any boards with this version. No clue if the underlying issue in Firefox was ever fixed.
Flags: needinfo?(gpascutto)
Per BugMaster and Comment 22 closing as invalid, should the error occur again feel free to reopen with detailed steps to reproduce.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.