Closed Bug 541380 Opened 10 years ago Closed 10 years ago

Piece of previous page's name on last tab

Categories

(Firefox :: Tabbed Browser, defect, trivial)

Other
Windows XP
defect
Not set
trivial

Tracking

()

RESOLVED DUPLICATE of bug 522392

People

(Reporter: andreluis.g.silva, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pt-BR; rv:1.9.2) Gecko/20100115 Firefox/3.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; pt-BR; rv:1.9.2) Gecko/20100115 Firefox/3.6

If the page's current title is so long that all of it doesn't fit in the tab's caption, if one switches to a page whose name is smaller, the last part of the previous page's text will still be visible in the place of the close tab button.
This only seems to happen when a single tab is open, and the close button isn't present, but browser.tabs.closeWindowWithLastTab is false.
This happened in Firefox 3.6.

Reproducible: Sometimes

Steps to Reproduce:
1. With a single tab open, enter a page with a long name
2. Change to a page whose name is really short
Actual Results:  
If all went well, part of the previous page's text should appear on the right of the tab.

Expected Results:  
Show blank space.

It must be on the first and only tab open. browser.tabs.closeWindowWithLastTab must be false. The tab bar should always be visible.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 522392
You need to log in before you can comment on or make changes to this bug.