Closed Bug 54142 Opened 20 years ago Closed 18 years ago

+ within integer attribute is stripped, should signal end of number

Categories

(Core :: Layout, defect, P2)

x86
Windows 98
defect

Tracking

()

RESOLVED FIXED
mozilla1.1beta

People

(Reporter: jruderman, Assigned: bzbarsky)

References

()

Details

(Keywords: testcase)

Attachments

(3 files)

http://www.flightgear.org/Gallery/ has a few images with height=128+0+0.  
Mozilla interprets this as height="12800".

Bug 52019 may be related.
Attached file test case
this is prolly nisheeth's area
Assignee: clayton → nisheeth
This bug has been marked "future" because the original netscape engineer working
on this is over-burdened. If you feel this is an error, that you or another
known resource will be working on this bug, or if it blocks your work in some way
-- please attach your concern to the bug for reconsideration.
Target Milestone: --- → Future
possible developer release note for rtm: see bug 52019.
Reassigning QA Contact for all open and unverified bugs previously under Lorca's
care to Gerardo as per phone conversation this morning.
QA Contact: lorca → gerardok
qa contact updated.
QA Contact: gerardok → bsharma
*** Bug 87638 has been marked as a duplicate of this bug. ***
SPAM. HTML Element component deprecated, changing component to Layout. See bug
88132 for details.
Component: HTML Element → Layout
OK to correct for quirks mode, but we should probably ignore the value for strict.
Keywords: testcase
Summary: + within integer attribute is stripped, should signal end of number → [quirks]+ within integer attribute is stripped, should signal end of number
I don't think we should ignore the value in standards mode.  That would be an 
unnecessary difference between quirks mode (display existing web pages as 
intended by page authors) and standards mode (display standards web pages as 
specifed by standards).
Summary: [quirks]+ within integer attribute is stripped, should signal end of number → + within integer attribute is stripped, should signal end of number
QA Contact: bsharma → moied
*** Bug 145427 has been marked as a duplicate of this bug. ***
Both of these patches make us work the same as IE5 and NS4 and pretty much the
same as opera.

ccing jag and jst, since the first patch touches jst's code and the second patch
(which I prefer, myself) is jag's code.

Thoughts?
Also see bug 119548 (should be marked as a duplicate). It seems that other
browsers (IE 5.5, Netscape 4) support this "+ in an integer attribute", and (to
me) the w3c standards do not seem clear on whether an integer data type means
just [0-9] or whether an integer includes simple math (+-*/).
The other browsers do not do any math.  They just drop the "+" and everything 
following it.  Try doing an image with |width="20+20"| to see that -- IE5, 
Opera, NS4 all render it 20 pixels wide, not 40 pixels.
Attachment #84173 - Flags: review+
Comment on attachment 84173 [details] [diff] [review]
not-so-safe-but-correct fix

jag says sr=jag
Attachment #84173 - Flags: superreview+
I'll take this.
Assignee: nisheeth → bzbarsky
Priority: P3 → P2
Target Milestone: Future → mozilla1.1beta
And checked in to trunk.
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → FIXED
*** Bug 79348 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.