Selected messages might have disabled toolbar buttons that should be enabled

RESOLVED WORKSFORME

Status

Thunderbird
Toolbars and Tabs
RESOLVED WORKSFORME
9 years ago
7 years ago

People

(Reporter: Will Pittenger, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6 GTB6 (.NET CLR 2.0.50727; .NET CLR 3.0.30729; .NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.7) Gecko/20100111 Thunderbird/3.0.1

When I use the new mail notification window to view new messages, TB will show me the e-mail I choose as it should.  But I noticed that all toolbar buttons on both the main toolbar and the new preview pane toolbar are disabled if they require a message to be selected.

The message is selected, but because the user didn't click it in the row, TB acts like the message isn't selected.

Most programs I have worked on use a loop that detects idle CPU time to check for out of date toolbar button statuses.  When the loop sees idle time, it checks to see if any states need to be changed.  Based on what I am seeing, TB doesn't do that or this bug wouldn't be here.

Reproducible: Always

Steps to Reproduce:
1. Wait for the new mail notification window to appear
2. Click a message in it
3. The message will be shown and highlighted as though it were selected, but the toolbar buttons will remain disabled
Actual Results:  
Even though a message might appear to be selected, some toolbar buttons that should be enabled won't be.

Expected Results:  
Regardless of how you view a message, the correct toolbar buttons should be enabled.

Note: TB is a 32-bit build.  The x86_64 part refers to my version of Windows Vista.
(Reporter)

Comment 1

9 years ago
When I filed this, I was thinking I saw it every time.  However, my memory was faulty.  It is more like 1 in 6 times.
Will, you still see this in current versions of TB (7+)?
(Reporter)

Comment 3

7 years ago
No.  I didn't even remember the bug.
thank you for feedback
wfm based on comment 3 (without further checks)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.