Address book during composition does not remember Primary address or Favorite

RESOLVED DUPLICATE of bug 497722

Status

Thunderbird
Address Book
RESOLVED DUPLICATE of bug 497722
8 years ago
8 years ago

People

(Reporter: Matt Krause, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6 (.NET CLR 3.5.30729)
Build Identifier: Thunderbird 3.0 Release version now deleted

When I compose a message and enter recipient names TB 3.0 does not remember my favorites nor does it list the "primary" email address first.
I have deleted TB3.0 and reverted to TB 2.0.23.
The problem does not occur under 2.0.23 despite using the same profile.

Reproducible: Always

Steps to Reproduce:
1.Compose message
2.Address message
3.Get wrong email address
Actual Results:  
Email will be addressed to either "email" or "additional Email" address without the primary one called first.
After repeatedly using the preferred / favorite email address it will continue to select what it pleases

Expected Results:  
Present the primary address first in the list of possibilities
Remember my favorite

I reverted to TB 2.0.23.
It performs as I expect
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 497722
You need to log in before you can comment on or make changes to this bug.