search box problem - will not properly overwrite selected text

RESOLVED WORKSFORME

Status

()

Firefox
Search
RESOLVED WORKSFORME
8 years ago
4 years ago

People

(Reporter: Pierre Marivaux, Unassigned)

Tracking

3.6 Branch
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.2) Gecko/20100115 Ant.com Toolbar 2.0 Firefox/3.6
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.2) Gecko/20100115 Ant.com Toolbar 2.0 Firefox/3.6

When I try to overwrite the text from a previous search (in the search box on the navigation toolbar) by selecting the previous text, the old text remains in the background while I type the new text.  This seems to happen more often when the previous text is longer than the visible length of the search box.  This did not happen in Firefox 3.5 for OSX.

Reproducible: Always

Steps to Reproduce:
1. Do a search with a search terms that extend beyond the length of the search box.
2. Switch to another tab
3. Return to the original tab
4. Highlight the Search terms using "select all"
5. Type new search terms
Try safe mode. Sounds like the ant toolbar could be causing this. http://support.mozilla.com/kb/Safe+Mode
Component: General → Location Bar and Autocomplete
QA Contact: general → location.bar
Version: unspecified → 3.6 Branch
I was seeing this on 10.4 frequently as well.  Maybe an invalidation bug in layout?
Status: UNCONFIRMED → NEW
Component: Location Bar and Autocomplete → Search
Ever confirmed: true
QA Contact: location.bar → search
Shawn, you mean it's 10.4 only?
I never saw it on my 10.5 box.  I probably should have filed a bug, but my 10.4 box had been acting weird in general, so I didn't think too much about it :/
(Reporter)

Comment 5

8 years ago
Thanks for the suggestion, Tyler, but I'm afraid that the behaviour is the same in safe mode, and I don't use the ant extension.  As to whether it happens on OS versions other than 10.4, I couldn't say.
(Reporter)

Comment 6

8 years ago
As a revision to my previous comment:  Sorry, I was using the Ant extension when reporting the bug (just noticed my reporting data above).  However, I have since removed the Ant Toolbar and the search box behavior is the same.
i have tested this with different profiles in actual Production FF27 and on Beta (Windows XP, 7)

could not find any problem like the described...

can someone check - so we can close this?
Thanks for checking. I also cannot reproduce.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.