Entire browser viewing area disappears, leaving tabs and status bar.

RESOLVED WORKSFORME

Status

()

Firefox
General
--
critical
RESOLVED WORKSFORME
9 years ago
8 years ago

People

(Reporter: verifex, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6 (.NET CLR 3.5.30729)

I was visiting CarnageBlender.com which uses frames and a java chat applet.  After surfing around on this site for a bit, I left it open and walked away for a few minutes.  When I came back, I saw that the entire browser viewing area had disappeared leaving the status bar nudged up against the bottom of the tabs on the screen, with the theme picture covering around 1/3 of the blank space left below, and then empty white space covering most of the screen.

I could see the screen was maximized, but hitting restore button or minimize didn't see to affect the screen being totally removed from itself.  Unfortunately because this bug seemed to happen while I was away I can't give anymore specifics then that.  Although, I've left it open on this screen a few times, and it has happened 2 times in the past day or so that I have had Firefox 3.6 installed.

Reproducible: Sometimes

Steps to Reproduce:
1. Open browser
2. Open carnageblender.com (involves signing in and opening frames/chat)
3. Click on a couple links, surf around and then leave browser open and walk away for a moment (make sure the fight feed on the sidebar is displaying properly)
Actual Results:  
The screen will disappear, only leaving the statusbar nudged up right underneath the tabs at the top.

Expected Results:  
Performs as intended, the screen should not disappear no matter how long I leave it on a screen with frames and java applet open.

Theme: Brushed Metal - Vista
Build config: i686-pc-mingw32
Built from http://hg.mozilla.org/releases/mozilla-1.9.2/rev/448d0d2d310c
cl  	14.00.50727.762  	 -TC -nologo -W3 -Gy -Fdgenerated.pdb -DNDEBUG -DTRIMMED -Zi -UDEBUG -DNDEBUG -GL -wd4624 -wd4952 -O1
cl 	14.00.50727.762 	-GR- -TP -nologo -Zc:wchar_t- -W3 -Gy -Fdgenerated.pdb -DNDEBUG -DTRIMMED -Zi -UDEBUG -DNDEBUG -GL -wd4624 -wd4952 -O1 
Build Arguments: --enable-application=browser --enable-update-channel=release --enable-update-packaging --enable-jemalloc --enable-official-branding --enable-tests 

I have disabled check 3.6 compatibility in the about:config so that I could use the "Password Hasher" add-on: https://addons.mozilla.org/en-US/firefox/addon/3282

I have the following add-ons installed and enabled and updated to their most recent versions except Password Hasher:
Adblock Plus, All-in-One Sidebar, Chickenfoot, Delicious Bookmarks, Download Statusbar, DownloadHelper, FEBE, Firebug, Greasemonkey, Interclue, Java Console, Jetpack, Mouse Gestures Redox: http://www.mousegestures.org/, NoScript, Password Hasher : http://wijjo.com/PasswordHasherInstall (There is a recent version that adds nothing but changes version numbers to work with 3.6, I have not installed this yet), Session Manager.
Do you get this without addons -> http://support.mozilla.com/en-US/kb/Safe+Mode ?
Please always test without addons before you report bug reports.

You mention java, which JRE version do you use ?
(Reporter)

Comment 2

9 years ago
I am running Version 6 Update 17 (build 1.6.0_170b04)

I have another correlating factor:  I have a Direct3D screensaver that seems to be running shortly before I have this problem.  When I had the browser open, surfed around a little, and left for a few minutes, the screensaver was on, and when I moved the mouse, the browser window was all broken.  I have a screenshot of it this time as well.
Update your video drivers. Then test in safe mode with java 6 update 18 and firefox 3.6.2 or later.
Reporter, are you still seeing this issue with Firefox 3.6.13 or later in safe mode? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles

You can also try to reproduce in Firefox 4 Beta 8 or later, there are many improvements in the new version, http://www.mozilla.com/en-US/firefox/all-beta.html
Whiteboard: [CLOSEME 2011-1-30]
(Reporter)

Comment 5

8 years ago
I haven't seen it happen in Firefox 3.6.13.  I think this might have been fixed, or it was the result of a faulty add-on that has been fixed.  Will let you know if I can manage to reproduce this bug again.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
Whiteboard: [CLOSEME 2011-1-30]
You need to log in before you can comment on or make changes to this bug.