Filters: Filtering does not work from Message Filters window

RESOLVED FIXED

Status

Penelope
General
--
minor
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: Anthony Meadow, Assigned: Matt Dudziak)

Tracking

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_2; en-us) AppleWebKit/531.21.8 (KHTML, like Gecko) Version/4.0.4 Safari/531.21.10
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.4pre) Gecko/20100105 Eudora/3.0b4

Filtering from the Message Filters window using the "Run Now" button does not work:
- if the focus is the message pane (for that message)
- If the focus is the folder view and a message is selected
- If all the messages in the folder view are selected 

However, if I try to filter using the Tools > Run Filters on Message or Tools > Run Filters on Folder everything behaves.

So apparently there's a bug associated with the Run Now button in the Message Filters window.

Reproducible: Always

Steps to Reproduce:
1. (Assuming you have some working filters in place... have emails that should be filterable with a specific filter in the current window)
2. Bring up Message Filters window (Tools > Message Filters... )
3. Try to filter messages (nothing happens)
4. Close Message Filters window or put it behind Mail & Newsgroups window
5. Try to filter messages using Tools > Run Filters on Window (filters work)


Expected Results:  
The "Run Now" button in the Message Filters window should run the selected filter on the selected mailbox. It does not - nothing happens.
(Assignee)

Comment 1

8 years ago
Confirmed. Problem is NOT present in Thunderbird 3.0 or 3.0.1.
Assignee: mozilla-bugs → beckley
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
OS: Mac OS X → All
Hardware: x86_64 → All
(Assignee)

Updated

8 years ago
Summary: Filtering does not work from Message Filters window → Filters: Filtering does not work from Message Filters window
(Assignee)

Updated

8 years ago
Assignee: beckley → mozilla-bugs
(Assignee)

Comment 2

8 years ago
This is now working internally so should be fixed in our next beta (8.0b9). If the problem is not fixed for you in that release, please let me know and re-open this bug.

Marking 'fixed' as a result of recent Thunderbird code integration.
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.