File menubutton doesn't hover

VERIFIED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
P3
normal
VERIFIED WORKSFORME
18 years ago
13 years ago

People

(Reporter: neil@parkwaycc.co.uk, Assigned: scottputterman)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Messenger's File menubutton doesn't exhibit any hover effects, perhaps because
it has been defined as a menu, not a menubutton?

Comment 1

18 years ago
I know there is at least one "hover" duplicate out there...
QA Contact: esther → nbaca

Comment 2

18 years ago
Currently I only the see a problem with the File button and would suggest
keeping this bug. Bug# 51544 reported problems with the Delete and Print hover
buttons and is marked as worksforme.

Comment 3

17 years ago
This applies to both Classic and Modern.  The File button is not the same type 
of button as all the others, so it's not getting the right styles.  A couple 
weeks ago I fixed the lack of a clicked image for the Modern hover button, but 
I didn't touch Classic which is lacking both hover & active, nor did I notice 
Modern's lack of hover.  Hopefully this will get PDT approval.

Comment 4

17 years ago
WORKSFORME: 2001011720, Windows98. Neil, can you reproduce this with the latest
nightly?
(Reporter)

Comment 5

17 years ago
It's almost fixed, but I it still hovers if it's disabled :-(

Comment 6

17 years ago
I checked 4.7 and it displays hover effects whether a button is enabled or
disabled. 

Comment 7

17 years ago
Which version of 4.x, and on which platform? Neither 4.75 for Windows nor 4.76 
for Mac OS have hover effects for the `File' button (or for any other disabled 
button that I can see). If they did, that would be a bug.

Comment 8

17 years ago
I was using an older version of Communicator on NT4. With 4.75 I now get the 
same results as you. I just want the behavior to be consistent.
This bug has laid still for more than one year,so I took the time and tested this

Works for me on (including no hover when disabled):
Mozilla 1.0.1 (linux)
Mozilla 1.2 nightly (windows)

Both in modern and classic

Im marking thie bug Works-for me, please reopen if I'm in error
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 10

15 years ago
Yeah, this was fixed almost a year ago now...
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.