xul:radiogroup orient can't be changed by theme developers though it should

RESOLVED DUPLICATE of bug 541799

Status

()

Firefox
Extension Compatibility
RESOLVED DUPLICATE of bug 541799
8 years ago
8 years ago

People

(Reporter: Nick, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6

I probably want to make a theme which will have all pref-panes arranged vertically, like in Firefox 1:
http://www.montana.edu/resnet/setup/firefox/firefox1.jpg

Reproducible: Always

Steps to Reproduce:
1.Try to change the orient of prefpanes using userChrome.css and Google and your knowledge
2.
3.
Actual Results:  
No success because in chrome://global/content/bindings/preferences.xml
There is a line 548:
<xul:radiogroup anonid="selector" orient="horizontal"  ...
Which fixes the orient, in XML.

Expected Results:  
It's a cosmetic, appearance issue, theme developers should be able to change it, and so should I with userChrome.css

Maybe it could be harmless for Firefox code developers to write instead
<xul:radiogroup anonid="selector" style="-moz-orient:horizontal;"  ...
So that theme developers can control the orient?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 541799
You need to log in before you can comment on or make changes to this bug.