If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

toolbar items, including bookmarks toolbar and add-on buttons, placed on auto-hide menubar do not work.

NEW
Unassigned

Status

()

Firefox
Toolbars and Customization
8 years ago
4 months ago

People

(Reporter: B.Seys88, Unassigned)

Tracking

Trunk
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(blocking2.0 -)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; nl; rv:1.9.2) Gecko/20100115 Firefox/3.6 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; nl; rv:1.9.2) Gecko/20100115 Firefox/3.6 (.NET CLR 3.5.30729)

I've put some icons of add-ons I only use once in a blue moon next to my menubar; and then set the menubar to autohide.

Whenever I need to click one of the icons, I used to ALT the menubar back, and then I could click on the icon of choice.

Today, I've upgraded to Firefox 3.6.

The above now works fine for add-on buttons which have a pop-up menu (like AdBlockPlus or FireShot); not for simple icons without popup menu like FireFTP and ChatZilla. Clicking these, the menubar just disappears, and my add-on doesn't show up like it should.

Reproducible: Always

Steps to Reproduce:
1. Add some simple (no pop-up menu) icons from add-ons next to the menubar 
2. Autohide the menubar.
3. Alt the menubar back.
4. Click on one of the add-on buttons.
Actual Results:  
The menubar will hide again, not showing up your add-on.

Expected Results:  
The add-on should have been opened (ChatZilla, FireFTP etc.)

Do the same thing with icons that have a pop-up menu like AdblockPlus or FireShot and these will work perfectly.
(Reporter)

Updated

8 years ago
Summary: Clicking add-on icons which are next to the menubar (on autohide) does nothing → Clicking add-on icons which are next to the menubar (on autohide) hides menubar without opening the clicked add-on
(Reporter)

Updated

8 years ago
Hardware: x86 → x86_64
Version: unspecified → 3.6 Branch

Comment 1

8 years ago
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a5pre) Gecko/20100408 Minefield/3.7a5pre ID:20100408075050
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.4pre) Gecko/20100408 Lorentz/3.6.4pre ID:20100408043726

Not only toolbarbutton of extension but also toolbar buttons of Bookmarks, History and print etc are not working when they are put on the menu bar.
Status: UNCONFIRMED → NEW
Ever confirmed: true
THis is the same issue i complained about in bug 498102 which was resolved as fixed without really fixing the issue.
Version: 3.6 Branch → Trunk
Duplicate of this bug: 542997

Updated

7 years ago
Summary: Clicking add-on icons which are next to the menubar (on autohide) hides menubar without opening the clicked add-on → toolbar items, including bookmarks toolbar and add-on buttons, placed on auto-hide menubar do not work.

Updated

7 years ago
Duplicate of this bug: 574761

Updated

7 years ago
blocking2.0: --- → ?

Comment 5

7 years ago
In hope that this information could be useful:

After filing Bug 542997 (which is a duplicate of this bug), I found an add-on that overrides this bug's behaviour and appears to enable the desired effect.

I can hit 'Alt' and click on an icon in the menubar and it now works...the icon I use most is the "Web Developer" icon, which displays the associated toolbar when the icon is clicked. The Menubar then disappears after the icons event have finished...as it should.

The add-on:
Hide Menubar
https://addons.mozilla.org/en-US/firefox/addon/4762/

This add-on was originally used to give this functionality when it was not native in Firefox.

Comment 6

7 years ago
I have the personal bookmark items on the menubar.  To work around this bug I find if I first click on any folder among the bookmark items then menubar will stay visible and any other item I click on the menubar will work and the menubar will the auto-hide.  

Why this trick works I have no idea.
(In reply to comment #6)
> Why this trick works I have no idea.

It's a bug.
Blocks: 477256
Would absolutely consider taking a patch for this, but not going to bock the release on it as it doesn't prevent or regress major functionality of the browser.
blocking2.0: ? → -

Updated

7 years ago
Duplicate of this bug: 621129

Updated

7 years ago
Duplicate of this bug: 623881

Updated

7 years ago
Duplicate of this bug: 626264

Comment 12

7 years ago
The problem seems to be the same on FF 4b10 as I mis-mentionned it in the bug "551616".

I am on a Win64 on a Win 7. Do I have to open another bug ?

So the same use case apply :
* Put the personnal bar(bookmarks with or without text) in the menu bar
* Press "Alt" to show up the menu bar ;
* Clik on your favorite and beloved bookmark, the one you open up every morging
;
* the menu bar hide itself and nothing happen ;

(pressing menus will work)

Comment 13

7 years ago
Created attachment 510399 [details]
Capture of the case
Duplicate of this bug: 628983

Comment 15

7 years ago
(In reply to comment #14)
> *** Bug 628983 has been marked as a duplicate of this bug. ***

on https://bugzilla.mozilla.org/show_bug.cgi?id=628983 you will find a Video who show this effect.

Updated

7 years ago
Duplicate of this bug: 633272

Comment 17

7 years ago
I found there is a rather easy workaround especially when using a touchpad. Right-click on the item before clicking it.

The click will go to the item and not to the context menu that will open.

Comment 18

7 years ago
Same issue in FF 4b12

Updated

7 years ago
Duplicate of this bug: 636712

Comment 20

7 years ago
Bug still present in Firefox 4.0 RC1 on Windows 7 x64.

Comment 21

7 years ago
Bug still present in Firefox 4.0 RC2 on Windows 7 x64.
(In reply to comment #21)
> Bug still present in Firefox 4.0 RC2 on Windows 7 x64.

Please do not add useless comments to the bug.  If it were fixed, the status would say FIXED.  Since the status still says NEW, adding comments saying it is still not fixed just ends up sending SPAM emails to people trying to fix it.
Duplicate of this bug: 643665

Updated

7 years ago
Duplicate of this bug: 644137

Updated

7 years ago
Duplicate of this bug: 644357

Updated

6 years ago
Duplicate of this bug: 657186

Comment 27

6 years ago
I can see it on Win XP 32bit, FF10. Fixing the Platform, even the original reported didn't have 64bit and it seems not relevant.
Hardware: x86_64 → x86

Comment 28

6 years ago
This bug seems to have gone on latest Nightlies.

Comment 29

6 years ago
I can still reproduce on
http://hg.mozilla.org/mozilla-central/rev/60edf587f4af
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0a1) Gecko/20120214 Firefox/13.0a1 ID:20120214031227

STR
1. Start Firefox with new profile
2. Open Customize toolbar  Dialog(Alt > View > Toolbars > Costmize...)
3. Drag "Bookmarks Toolbar Items" to Menubar
4. Done to close dialog
5. Restart Firefox (if any)
6. Push Alt key 
7. Click "Getting Started" bookmark on the Toolbar

Actual Results:
  Nothing happens

Expected Results:
  The bookmark should open

Updated

5 years ago
Duplicate of this bug: 856324

Comment 31

3 years ago
Menubar: the most mystic area of Firefox, you can place as many items as you want in it, but you can never click them

Comment 32

4 months ago
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:54.0) Gecko/20100101 Firefox/54.0
Built from https://hg.mozilla.org/releases/mozilla-aurora/rev/94b7e538af7dbb9a6567cad9125c2f5411e7fb80

"Click on menu then click add-on icons" no longer works.

However, some add-on icons works for reason I don't know, found two so far:
- User Agent Switcher 0.7.3.1 (https://addons.mozilla.org/zh-CN/firefox/addon/user-agent-switcher/)
- ColorZilla 2.8.2 (https://addons.mozilla.org/zh-CN/firefox/addon/colorzilla/versions/?page=1#version-2.8.2)

1. Install add-ons listed above (restart Firefox if needed), 
2. Open `Customize` dialogue
3. Click `Show/Hide Toolbars`, uncheck `Menu Bar` to enable the autohide of menubar.
3. Drag `ColorZilla` and `Default User Agent` icon to menubar
4. Submit changes by click `Exit Customize`
5. Press left `Alt` key
6. Click the drop arrow to the right of `ColorZilla` icon, or click `Default User Agent` icon.

Result & Expected result:
- Drop menu of `ColorZilla` and `User Agent Switcher` stay open after click, menubar not hiding. (i.e. their icon works)
- You can click anywhere you like (including another add-on icon on menubar that you can't click before because menubar auto hides before the click finished) until left/right `Alt` key is pressed again.

Note:
* Latest version (3.3) of `ColorZilla` is not tested.
* Only the drop arrow of `ColorZilla` works, but not the icon itself.
You need to log in before you can comment on or make changes to this bug.