Text "selection" events interfere with rendering

RESOLVED WORKSFORME

Status

()

Core
SVG
--
minor
RESOLVED WORKSFORME
8 years ago
6 years ago

People

(Reporter: Helder "Lthere" Magalhães, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(status2.0 wanted)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.3a1pre) Gecko/20100124 Minefield/3.7a1pre (.NET CLR 3.5.30729)

When a text selection event occurs in this particular page, a rendering issue happens: a gradient unexpectedly "disappears".

Reproducible: Always

Steps to Reproduce:
1. Open the bug's URL [1];
2. "Select" all text (using "Edit"/"Select All" or the "Ctrl+A" keyboard shortcut).


Actual Results:  
The pen clip partially disappears.

Expected Results:  
No rendering changes as text selection isn't supported yet (bug 292498).

Another way of triggering the bug is by dragging (mousedown+mousemove) and/or double/triple clicking text, which are also text selection events.

Yet another way of triggering it is using Firebug 1.5. When it is opened and/or used highlight portions of the document (using the HTML tab), the rendering issue is even greater and I don't know whether that's a separate bug...

There seems to be a small text rendering change in the left yellow label "Pure Emacs", when the text selection events occur: I'm not sure if things can be related...

The issue may also be due to HTML content which is presented as fallback to browsers not supporting SVG (such as IE). The page is composed of two SVG documents (one for the background gradient, another one with most graphical content).

This behavior was already reported a few months ago in a blog post [2] but only now was I able to formally report it. Sorry for the delay! ;-)

I've checked that this still occurs in both 3.5.x (previous) stable release [3] and in a 3.7a1 nightly build [4].


Workaround:
A simple workaround seems to be hovering in the "Download" button or reloading the page.


[1] http://www.emacsformacosx.com/
[2] http://heldermagalhaes.com/blog/2009/08/emacs-triggers-svg-bugs/
[3] Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7 (.NET CLR 3.5.30729)
[4] Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.3a1pre) Gecko/20100124 Minefield/3.7a1pre (.NET CLR 3.5.30729)
(Reporter)

Comment 1

8 years ago
Created attachment 423283 [details]
Cropped screenshot following the steps to reproduce
(Reporter)

Comment 2

8 years ago
Created attachment 423284 [details]
Cropped screenshot using the Firebug procedure in additional details

Comment 3

8 years ago
Needs a reduced testcase.
(Reporter)

Comment 4

8 years ago
(In reply to comment #3)
> Needs a reduced testcase.

Will try to, thanks for the interest.


Just confirmed this in (previous release) 3.5.x [1] on Ubuntu 9.10. Assuming this is happening in all platforms (although I'm aware that Windows+Linux!=All, it generally is the case). Please confirm otherwise!


[1] Mozilla/5.0 (X11; U; Linux i686; pt-PT; rv:1.9.1.7) Gecko/20100106 Ubuntu/9.10 (karmic) Firefox/3.5.7(In reply to comment #3)
OS: Windows Vista → All
(Reporter)

Comment 5

7 years ago
Seeing this on trunk [1] and taking the opportunity to confirm, even with DirectWrite enabled (Direct2D is *not* enabled due to issues in my system - can anyone else confirm?).


[1] Mozilla/5.0 (Windows NT 6.0; rv:2.0b8pre) Gecko/20101205 Firefox/4.0b8pre
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → Trunk

Comment 6

7 years ago
I see it. I'd even try to fix it if I got the reduced testcase.

Updated

7 years ago
status2.0: --- → wanted

Comment 7

6 years ago
Gone in Firefox 9.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.