Scroll wheel input ignored

RESOLVED DUPLICATE of bug 207256

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 207256
8 years ago
8 years ago

People

(Reporter: IU, Unassigned)

Tracking

({qawanted})

Trunk
x86
Windows XP
qawanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [I need to investigate this some more...], URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a1pre) Gecko/20100124 BetterPrivacy-1.47 Minefield/3.7a1pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a1pre) Gecko/20100124 BetterPrivacy-1.47 Minefield/3.7a1pre ID:20100124045447

When linked page contains a flash-based flyer.  Scrolling the mouse wheel up or down is supposed to flip the flyer pages.  This is the behavior with IE and Chrome.  Firefox, with IPC is frequently unresponsive to scroll-wheel input, and is completely unresponsive on the linked page.


Reproducible: Always

Steps to Reproduce:
1. Load: http://www.nestersmarket.com/yaletown/
2. Using only your mouse wheel (i.e. scrolling up or down), attempt to flip through the flyer pages.  Nothing will happen.
3. IE and Chrome work properly

Actual Results:  
IPC ignoring scroll-wheel input.
(Reporter)

Updated

8 years ago
Blocks: 531142
Version: unspecified → Trunk
(Reporter)

Comment 1

8 years ago
Well, looks like something else is amiss.  Need to do some more investigating...
No longer blocks: 531142
Severity: major → normal
Component: IPC → General
Keywords: qawanted
Product: Core → Firefox
Summary: [OOPP] Scroll wheel input ignored → Scroll wheel input ignored
Whiteboard: [I need to investigate this some more...]
Scrolling the mouse wheel up or down doesn't work with dom.ipc.plugins.enabled
= false either. This is probably going to be a dupe of
https://bugzilla.mozilla.org/show_bug.cgi?id=207256.
Or more likely a dupe of https://bugzilla.mozilla.org/show_bug.cgi?id=409669.
(Reporter)

Comment 4

8 years ago
@Brian.  That's possible.

Both IE and Chrome allow the flyer pages to flip, with scrolling, as soon as the page is loaded.  Firefox is really picky and will only flip with scrolling if the mouse pointer is in the region of the black bar at the bottom of the flyer pages.  I was thinking it could be a regression from either bug 526394 or Bug 178324, but you're probably right.

I'll do some more checking before deciding to dupe.
(Reporter)

Comment 5

8 years ago
OK; duping to Bug 207256.  It would be nice if someone actually fixed that bug.  I'm running into it a lot more with IPC than without (even when the flash object should not have focus), which is why I initially thought this was an IPC issue.
(Reporter)

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 207256
You need to log in before you can comment on or make changes to this bug.