Typing space in a form takes you to bottom of page

RESOLVED WORKSFORME

Status

()

Core
Layout
P3
normal
RESOLVED WORKSFORME
19 years ago
16 years ago

People

(Reporter: Stephen P. Morse, Assigned: saari (gone))

Tracking

({access})

Trunk
mozilla1.0
x86
Windows NT
access
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Go to any page that has a form to fill in.  Don't know any?  Then try the menu
item edit/wallet/samples and pick one of those.  Start to enter data into any
field.  Tape a space in the field.  Suddenly browser will scroll down to the
very bottom of the page.  This is a regression that just started happpening with
this morning's build.

Updated

19 years ago
Assignee: chofmann → karnaze

Comment 1

19 years ago
karnaze, any ideas on this bug or who it should go to?

Comment 2

19 years ago
I don't know what caused this especially if it just happened today. It exhibits
the same behavior in viewer as well. There is code in
nsFormControlFrame:HandleEvent which checks for the NS_VK_SPACE key event but it
doesn't do anything that could cause the page to scroll down (and that code has
been there more than a couple of weeks). Tom would be the best to track it down,
but he probably had nothing to do with it, since he has been out of town. I'm
reassigning to Tom, but I'm not sure when he gets back. I'm also adding Patrick
to the CC list, because although nsFormControlFrame:HandleEvent set the event
status to eConsumeDoDefault, it appeared that a bunch of views got a crack at
the event after that.

Comment 3

19 years ago
I don't know what caused this especially if it just happened today. It exhibits
the same behavior in viewer as well. There is code in
nsFormControlFrame:HandleEvent which checks for the NS_VK_SPACE key event but it
doesn't do anything that could cause the page to scroll down (and that code has
been there more than a couple of weeks). Tom would be the best to track it down,
but he probably had nothing to do with it, since he has been out of town. I'm
reassigning to Tom, but I'm not sure when he gets back. I'm also adding Patrick
to the CC list, because although nsFormControlFrame:HandleEvent set the event
status to eConsumeDoDefault, it appeared that a bunch of views got a crack at
the event after that.

Comment 4

19 years ago
*** Bug 4921 has been marked as a duplicate of this bug. ***

Comment 5

19 years ago
This seems to be a duplicate of a much earlier bug that had to do with not
directing keypresses to the appropriate part of the application. Of course, I'm
clueless and don't know that earlier bug number. Anyone?

Comment 6

19 years ago
This bug severly impacts editor usability. M6.

Updated

19 years ago
Target Milestone: M6

Comment 7

19 years ago
Well, I misread the summary slightly; problems in editor are similar to problems
in forms. Perhaps this is a dup of 3999?

Comment 8

19 years ago
Well, I misread the summary slightly; problems in editor are similar to problems
in forms. Perhaps this is a dup of 3999?

Comment 9

19 years ago
*** Bug 5515 has been marked as a duplicate of this bug. ***
(Reporter)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 10

19 years ago
This is now working correctly in a current build.  Closing as "works-for-me"

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 11

19 years ago
In the 5/17 Build, the typing space in a forms works correctly.
*** Bug 59192 has been marked as a duplicate of this bug. ***
Someone is reporting this again.  Please see bug #59192 for details.
Status: VERIFIED → REOPENED
Resolution: WORKSFORME → ---

Comment 14

17 years ago
I haven't seen this problem for a while now in recent builds on linux or
windows.  Is anyone else still seeing this?

Comment 15

17 years ago
Several other recent reports: see bug 26822.

Comment 16

17 years ago
Bug 26882 contains instructions on how to reproduce this behavior reliably, on
Windows and Linux (I'm not sure whether anyone's tried it on Mac).

Comment 17

17 years ago
Akkana, are you sure that you mentioned the right bug number?  That one doesn't
sound like it.

Comment 18

17 years ago
See my second comment (bug 26882), not my first one (where I mistyped the number).

Updated

17 years ago
Depends on: 26882
Chris, you were fixing this (have fixed this earlier), right? If not, just pass
this back...
Assignee: joki → saari
Status: REOPENED → NEW
Keywords: access
Target Milestone: M6 → ---
(Assignee)

Comment 20

17 years ago
accepting
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9
*** Bug 66652 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9 → mozilla1.0

Comment 22

17 years ago
makingtest - ziz@ziz.org

Comment 23

17 years ago
worksforme - ziz@ziz.org

Comment 24

17 years ago
Adding myself to Cc list.

Comment 25

17 years ago
*** Bug 69506 has been marked as a duplicate of this bug. ***

Comment 26

17 years ago
I haven't seen this in a long time.
Can we mark it resolved/WORKSFORME?
(Assignee)

Comment 27

16 years ago
Yeah, I think this is works for me now
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.