middle mouse button does not work on an inactive window

RESOLVED FIXED in mozilla1.9.3a5

Status

()

Core
General
--
minor
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: Thomas, Assigned: mstange)

Tracking

({regression})

1.9.2 Branch
mozilla1.9.3a5
All
Mac OS X
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6

Using mouse3 (middle mouse button) on a window closes the tab (if on a tab) or opens a new tab (if on a link) under default conditions. 3.5.x had this ability, but after upgrading to 3.6, this functionality no longer works on an INACTIVE window.

Reproducible: Always

Steps to Reproduce:
1. Open window 1
2. Open window 2
3. With window 2 active, mouse3 click a link or tab in window 1
Actual Results:  
Nothing

Expected Results:  
Tab closes (if on a tab) or tab opens (if on a link)

This was working in Firefox < 3.6

Updated

8 years ago
Component: Tabbed Browser → General
Keywords: regressionwindow-wanted
Product: Firefox → Core
QA Contact: tabbed.browser → general
Summary: mouse3 does not work on an inactive window → middle mouse button does not work on an inactive window
Version: unspecified → 1.9.2 Branch
Can you please run Firefox in Safe Mode (http://support.mozilla.com/kb/Safe+Mode) and check this again with all add-ons disabled? Thanks.
(Reporter)

Comment 2

8 years ago
Safe Mode made no difference.
Thomas, would you have time to check the beta releases of Firefox 3.6 and find out when this problem occurred for the first time? Would be nice to have a smaller regression range.
Keywords: regression
(Reporter)

Comment 4

8 years ago
3.7 NB, 3.6.1 NB 3.6 RC2, 3.6 RC1, 3.6 B4, all have the issue.
3.5.7 latest does not.
(Reporter)

Comment 5

8 years ago
Also, I noticed that when using 3.5.7, the default action for a .dmg was "Open With Disk Mounter" but >=3.6 is "Open With ..." (Click to choose)
(In reply to comment #4)
> 3.7 NB, 3.6.1 NB 3.6 RC2, 3.6 RC1, 3.6 B4, all have the issue.
> 3.5.7 latest does not.

Can you please go back to B4 -> A1? It would be great if you have that time. 

(In reply to comment #5)
> Also, I noticed that when using 3.5.7, the default action for a .dmg was "Open
> With Disk Mounter" but >=3.6 is "Open With ..." (Click to choose)

That one should be handled by another bug. But please test with a fresh profile first before filing a new one.
(Assignee)

Comment 7

8 years ago
I think I regressed this in bug 443178. Please confirm.
Thomas, regarding the information from Markus it would be great if you could test the following to builds. While the first one should work the latter one fails.

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2009/11/2009-11-18-03-mozilla-1.9.2/

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2009/11/2009-11-19-03-mozilla-1.9.2/
(Reporter)

Comment 9

8 years ago
(In reply to comment #6)
> Can you please go back to B4 -> A1? It would be great if you have that time. 
I couldn't find anything before B4. If you could send a link I can try it.
(someone posted links to these as I was commenting...)


(In reply to comment #7)
> I think I regressed this in bug 443178. Please confirm.
I don't think tooltips are the cause of this.
(Reporter)

Comment 10

8 years ago
(In reply to comment #9)
> (someone posted links to these as I was commenting...)

Actually, I already tested those versions. (:
(Assignee)

Comment 11

8 years ago
(In reply to comment #7)
> I think I regressed this in bug 443178. Please confirm.

Confirmed. Thanks for the links to the builds, Henrik.

Actually, I regressed this twice: After bug 443178, middle-clicking an inactive window only failed when the Firefox *application* is active. Then in 515003 I also broke it for inactive windows in inactive applications.

(In reply to comment #9)
> (In reply to comment #7)
> > I think I regressed this in bug 443178. Please confirm.
> I don't think tooltips are the cause of this.

The patch in that bug didn't only touch tooltips.

(In reply to comment #10)
> Actually, I already tested those versions. (:

Those builds are nightly builds. They change almost daily, not only when their version number changes.
Blocks: 443178, 515003
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regressionwindow-wanted
(Assignee)

Comment 12

8 years ago
Created attachment 443377 [details] [diff] [review]
v1
Assignee: nobody → mstange
Status: NEW → ASSIGNED
Attachment #443377 - Flags: review?(joshmoz)
(Assignee)

Updated

8 years ago
Attachment #443377 - Attachment is obsolete: true
Attachment #443377 - Flags: review?(joshmoz)
(Assignee)

Comment 13

8 years ago
Comment on attachment 443377 [details] [diff] [review]
v1

This doesn't fix sheets yet.
(Assignee)

Comment 14

8 years ago
Created attachment 443393 [details] [diff] [review]
v2
Attachment #443393 - Flags: review?(joshmoz)
(Assignee)

Comment 15

8 years ago
Comment on attachment 443393 [details] [diff] [review]
v2

still not ready
Attachment #443393 - Flags: review?(joshmoz)
(Assignee)

Comment 16

8 years ago
Created attachment 443614 [details] [diff] [review]
v3

Difference to the previous patch is that we don't want to let mouse *move* events through to inactive windows, even when Cmd is pressed.
Attachment #443393 - Attachment is obsolete: true
Attachment #443614 - Flags: review?(joshmoz)

Updated

8 years ago
Attachment #443614 - Flags: review?(joshmoz) → review+
(Assignee)

Comment 17

8 years ago
http://hg.mozilla.org/mozilla-central/rev/f12a2ee5469e
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Hardware: x86_64 → All
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.3a5
You need to log in before you can comment on or make changes to this bug.