after update to 3.6: browser suggests to save file home.htm or open it with another application

RESOLVED INVALID

Status

()

Firefox
File Handling
RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: arjan, Unassigned)

Tracking

3.6 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6 (.NET CLR 3.5.30729)

I updated my Firefox from 3.5x to 3.6 and since that moment the following page doesn't open correctly anymore. I don't know if it is a problem with the website, but is has never been a problem so far. 

When I enter the URL http://www.skl.de/fwd?to=1_home.jsp the page isn't being displayed as a web page. Instead Firefox offers to save the file or open it with another application. When i choose Firefox as application the file opened is named file:///C:/DOCUME~1/Arjan/LOCALS~1/Temp/home-1.htm. My JRE had been updated only a few days before I updated Firefox. 

Reproducible: Always

Steps to Reproduce:
1.http://www.skl.de/  [or directly from point 2]
2.http://www.skl.de/fwd?to=1_home.jsp
3.
Actual Results:  
Page doesn't open like expected.

Expected Results:  
The website should have opened like any other website does.
(Reporter)

Updated

8 years ago
Summary: after update to 3.6: browser suggests to save file home.htm of open it with another application → after update to 3.6: browser suggests to save file home.htm or open it with another application
(Reporter)

Updated

8 years ago
Version: unspecified → 3.6 Branch

Comment 1

8 years ago
For me that redirects to http://www.skl.de/mobil/home.htm;jsessionid=randomstuff which is served with the following HTTP header:

Content-Type: application/vnd.wap.xhtml+xml; charset=UTF-8

which doesn't seem to be listed at http://www.iana.org/assignments/media-types/application/ as a real type, and being unknown leads Firefox to prompt for further action.

It looks like they have a simple error on the server end with the content-type header.
Assignee: nobody → german
Status: UNCONFIRMED → NEW
Component: General → German
Ever confirmed: true
Product: Firefox → Tech Evangelism
QA Contact: general → german
Summary: after update to 3.6: browser suggests to save file home.htm or open it with another application → after update to 3.6: browser suggests to save file home.htm of open it with another application
Version: 3.6 Branch → unspecified
(Reporter)

Comment 2

8 years ago
Why wasn't this a problem in all versions previous to version 3.6?
And why is it suddenly a problem?

(I am not super technical and certainly not a Firefox expert. I just experienced this problem directly after updating Firefox.)
Component: German → File Handling
Product: Tech Evangelism → Firefox
Version: unspecified → 3.6 Branch
(Reporter)

Updated

8 years ago
Summary: after update to 3.6: browser suggests to save file home.htm of open it with another application → after update to 3.6: browser suggests to save file home.htm or open it with another application

Updated

8 years ago
Status: NEW → UNCONFIRMED
Ever confirmed: false
Assignee: german → nobody
QA Contact: german → file.handling
marking invalid based on comment #1 (and it works again for me)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.