just approven addon (xpi file) isn't available right away

RESOLVED WORKSFORME

Status

addons.mozilla.org Graveyard
Public Pages
P3
minor
RESOLVED WORKSFORME
8 years ago
2 years ago

People

(Reporter: Henrik Gemal, Unassigned)

Tracking

unspecified
4.x (triaged)

Details

(Whiteboard: [ReviewTeam])

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
my addon Validaty just got approved.

so I did a search for updates and Firefox found that an update for validaty was avaiable.

It called the following URL:
https://versioncheck.addons.mozilla.org/update/VersionCheck.php?reqVersion=2&id=validaty@gemal.dk&version=1.4.1&maxAppVersion=3.7a1pre&status=userEnabled&appID={ec8030f7-c20a-464f-9b0e-13a3a9e97384}&appVersion=3.6&appOS=WINNT&appABI=x86-msvc&locale=en-US&currentAppVersion=3.6&updateType=97

But the actual XPI file:
http://releases.mozilla.org/pub/mozilla.org/addons/2609/validaty-1.5.0-fx.xpi

wasn't yet available to download so I got a download error.

Must be some kind of sync problem. Perhaps the update information shouldn't be written until the actual XPI file is availble
I'm not sure if something can be done due to the complexity of the system, but it would be ideal to write the update file as the last step of the process.
Severity: normal → minor
Priority: -- → P4
Target Milestone: --- → 4.x (triaged)
Created attachment 425370 [details]
broken xpi file: 404 error page

I heard from an add-on author that this had happened occasionally, and I've confirmed such XPI files were 404 Not Found.
The following add-ons updated today are 404 not found:
https://addons.mozilla.org/en-US/firefox/addon/4496
https://addons.mozilla.org/en-US/firefox/addon/4550
https://addons.mozilla.org/en-US/firefox/addon/9608
https://addons.mozilla.org/en-US/firefox/addon/9924
https://addons.mozilla.org/en-US/firefox/addon/10174
https://addons.mozilla.org/en-US/firefox/addon/13373
We're receiving lots of reports of this in the amo-editors list.
Severity: minor → major
Component: API → Public Pages
Priority: P4 → P2
QA Contact: api → web-ui
Whiteboard: [required amo-editors]
Target Milestone: 4.x (triaged) → 5.7
Acutally, Bug 544587 is the one discussing the recent problems with XPI files (Comments 2,3 and 4). This bug is about something else.
Severity: major → minor
Priority: P2 → P3
Target Milestone: 5.7 → 4.x (triaged)
I believe this has been dealt with in several other bugs. If you can still reproduce, please comment or reopen.
-> WFM
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
Reclassifying editor bugs and changing to a new whiteboard flag. Spam, spam, spam, spam...
Whiteboard: [required amo-editors] → [ReviewTeam]
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.