Wrong display name is shown for shared email addresses

RESOLVED DUPLICATE of bug 474721

Status

Thunderbird
Message Reader UI
RESOLVED DUPLICATE of bug 474721
8 years ago
4 years ago

People

(Reporter: Trevor Morgan, Unassigned)

Tracking

(Depends on: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.5) Gecko/20091204 Lightning/1.0b1 Thunderbird/3.0

When 'Use display names from my address book' is on, The wrong name is displayed where there are multiple address book entries with the same email address - even when there is an exact match to the display name.

Reproducible: Always

Steps to Reproduce:
1. Create an address book entry for "John Smith <smith@somewhere.com>"
2. Create an address book entry for "Mary Smith <smith@somewhere.com>"
3. Find an email to/from "Mary Smith <smith@somewhere.com>"
Actual Results:  
The mail is shown to/from "John Smith"

Expected Results:  
The mail is shown to/from "Mary Smith"



I suggest that if there are multiple people with the same address, the display name is checked and the best match selected. (or display the received name+email if there is not an exact match).
(Reporter)

Comment 1

8 years ago
This is related to but, I think, different from Bug 189895.
(In reply to comment #1)
> This is related to but, I think, different from Bug 189895.

Why is it different ?
(Reporter)

Comment 3

8 years ago
(In reply to comment #2)
> (In reply to comment #1)
> > This is related to but, I think, different from Bug 189895.
> 
> Why is it different ?
Bug 189895 is about the way mailing lists are stored.  There should always be an exact one-to-one relationship between mailing list entries and address book entries - even when there are identical address book entries.

This issue is about finding the best address book match to incoming Names and e-mail addresses.  In this case there could be several address book entries that match wholly or partially.

They are related because bug 189895 could be fixed done by searching the address book with name + e-mail.  Or it could be fixed by adding a unique reference.  The former would (almost) fix this too.  The latter wouldn't.

The ideal solution would check for variants (e.g. "J Smith", "Smith, John").  But exact matching would probably be acceptable, given that there is likely to only be a small number of variants of someone's display name that people use.
(Reporter)

Updated

6 years ago
Depends on: 189895

Comment 4

6 years ago
(assuming this behavior hasn't changed - please close bug if that isn't true)
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

4 years ago
I think the way you'd handle this issue now is to uncheck "Always prefer display name over message header" for the contact(s) in question.

Feel free to reopen this if for some reason it doesn't resolve the issue.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 474721
You need to log in before you can comment on or make changes to this bug.