Personas localized pages show garbage characters

VERIFIED FIXED in 2.4

Status

Websites Graveyard
getpersonas.com
--
major
VERIFIED FIXED
8 years ago
5 years ago

People

(Reporter: kohei, Assigned: rdoherty)

Tracking

unspecified

Details

(URL)

(Reporter)

Description

8 years ago
http://personas.stage.mozilla.com/ja/gallery/All/Popular

<title> and <h2> contain garbled characters.
They should be "Personas ギャラリー"

Also confirmed at

http://personas.stage.mozilla.com/zh-TW/
(Assignee)

Updated

8 years ago
Target Milestone: --- → 2.4
(Reporter)

Comment 1

8 years ago
I think this is a regression by r61163. Workaround:

Replace htmlentities($string) with htmlentities($string, ENT_QUOTES, 'UTF-8') 

or 

Replace htmlentities($string) with htmlspecialchars($string)
(Reporter)

Comment 2

8 years ago
(In reply to comment #1)
> Replace htmlentities($string) with htmlspecialchars($string)

htmlspecialchars also requires charset, so it should be

htmlspecialchars($string, ENT_QUOTES, 'UTF-8')
(Assignee)

Updated

8 years ago
Duplicate of this bug: 542330
(Assignee)

Updated

8 years ago
Assignee: nobody → rdoherty
(Assignee)

Comment 4

8 years ago
r61461
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Reporter)

Updated

8 years ago
Status: RESOLVED → VERIFIED
(Assignee)

Updated

8 years ago
Duplicate of this bug: 543328
Component: getpersonas.com → getpersonas.com
Product: Websites → Websites Graveyard
You need to log in before you can comment on or make changes to this bug.