Opening URL in FF from external app doesn't restore minimized window

RESOLVED WONTFIX

Status

()

Core
Widget: Cocoa
RESOLVED WONTFIX
8 years ago
5 years ago

People

(Reporter: bwelling, Unassigned)

Tracking

1.9.2 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6

When opening a link from an external application, the page is properly loaded into a new tab in an existing firefox window, but if the window is minimized, the window isn't raised (as it was before firefox 3.6).

This is even worse when the link requires authorization, as the username/password aren't prompted for, and firefox unhelpfully displays an "Authorization Required" page on the tab (of the minimized window).

Reproducible: Always

Steps to Reproduce:
1.minimize firefox
2.click on link from external application
3.
Actual Results:  
the firefox window is not displayed, but the page is visible in a new tab once the window is opened

Expected Results:  
the firefox window should be restored and raised, with the page visible in a new tab

No themes, and the only add-on is Right-Click-Link.
I can reproduce this on OS X (10.5.8), as follows.  The problem
doesn't happen when you double-click on a local *.html file.

1) Start FF 3.6 or a current Minefield nightly.

   Make sure FF/Minefield is set as the OS's default browser:

   a) Open Firefox : Preferences : Advanced : General
   b) Click on the "Check Now" button in the dialog's bottom right.

2) Minimize the single browser window that appears.

3) Open Terminal and use 'open' on the commandline to open an *.html
   file.  For example:

   $ open Desktop/whatever.html

   The browser loads the page, but the window stays minimized.

Here's the regression range:

firefox-2009-06-16-03-mozilla-central
firefox-2009-06-17-03-mozilla-central

This almost certainly implicates Neil Deakin's patch for bug 497565:
http://hg.mozilla.org/mozilla-central/rev/ec9034099c13
Status: UNCONFIRMED → NEW
Component: General → Widget: Cocoa
Ever confirmed: true
Product: Firefox → Core
QA Contact: general → cocoa
Version: unspecified → 1.9.2 Branch
Blocks: 497565
Summary: opening external links doesn't open existing browser window → Opening URL in FF from external app doesn't restore minimized window

Comment 2

8 years ago
I think this is a dupe of bug 525759.

I wonder if attachment 421299 [details] [diff] [review] from bug 516027 fixes this. (I'll have to test later.)

Comment 3

8 years ago
Indeed, attachment 421299 [details] [diff] [review] fixes this bug, for the STR of both comment 0 and comment 1. (To perform the STR of comment 0, I go to Help -> VirtualBox Web Site... in VirtualBox.)

Updated

8 years ago
Duplicate of this bug: 525759

Updated

8 years ago
Duplicate of this bug: 545779

Comment 6

8 years ago
This only occurs in Snow Leopard and it's completely reproducible.

Comment 7

8 years ago
Sorry, it isn't an Snow Leopard problem, it occurs in Leopard too. I have Leopard on both of my machines and got this bug.

Comment 8

8 years ago
And when will this annoying bug be solved??

Comment 9

8 years ago
It's really annoying. I started using Safari but missing some of my addons including Firebug. So I'm using Firefox for developement only. Hope they will fix this bug soon.

Comment 10

8 years ago
I noticed that Bug 516027 fixed this bug.

Comment 11

8 years ago
First saw this with 3.6 on Tiger (PPC). Revert to 3.5.x worked fine. Tried again (3.6.x) on Leopard (PPC). Same results. Tried again on Snow Leopard. Same results. Probably related to Bug 531552.
As best I can tell, this problem no longer happens on OS X 10.6.8 and up.  On those versions of OS X, I can no longer reproduce my STR from comment #1 (testing with FF 17.0.1).

Since we no longer support OS X 10.5.X on current trunk, I'm marking this bug WONTFIX.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.